Welcome to the Corvette Forums at the Corvette Action Center!

Search results

  1. D

    New Member

    On my ASR/ABS service lights on I disconnected battery for a few minutes reconnected and the lights have not returned. The brake peddle is normal. So far so good.
  2. D

    New Member

    Wayback My mechanic found his old diagnostic computer and plugged it in under dash driver side. Came up with code 76. Description: Lateral Accelerometer Signal Out of Range. Parameters: Rating greater than 0.6g for an extended period of time. Can you put this in laymen's terms. What do I do with...
  3. D

    New Member

    Today I cleaned the throttle body. I sprayed all around I then wiped it out. Actually it wasn't that dirty. I also installed a new air filter. Car seemed to have more pep but still had that miss when stopped. It does not miss when in park only when in gear (Automatic Trans). Could it be a vacuum...
  4. D

    New Member

    No I do not show any codes on speedometer display. I opened that link you attached I myself would not know what to do. But I'll let my mechanic look at it. Thanks
  5. D

    New Member

    Thanks for the response Tuna, That's a sensor on each wheel correct. Could it be the ASR unit? My other question on Throttle body what are the idle air circuit's.
  6. D

    New Member

    Hello, Glad to be aboard. Have a couple of issues on my 92 C4. 1. Car has a jumpy idle at a stop light or any stop. Runs smooth on highway but around town when I stop it will idle fine then hiccup or stumble seems like it might stall but doesn't. 2. When I go over a bump and apply brakes I...
Top Bottom