Welcome to the Corvette Forums at the Corvette Action Center!

72 horn relay

Joined
Feb 1, 2002
Messages
185
Location
Falls Church, Va
Corvette
1972 Coupe ZZ4 / 4 Speed
Does anyone know which lead is which on the bottom of the relay? Which side is supposed to be the green wire and which the black?

Here is my problem. The horn doesn't work. If I jump the green wire (at the relay) to hot the horn sounds.

If I put a test light between hot and the black lead and press the horn button I get nothing.

Also, if I connect the side of the relay the black wire was on to ground I get nothing. No click, no horn.

I may have two problems... or perhaps the relay leads on on backwards...

On my car, if you are looking straight at the relay the green one is on the left. The black lead is on the right towards the front of the car.


Thanks!

-Gooney
 
1

194375s

Guest
If you remove the relay you can only put the green and black on one terminal(assuming you have original wiring)
 
Joined
Feb 1, 2002
Messages
185
Location
Falls Church, Va
Corvette
1972 Coupe ZZ4 / 4 Speed
Actually the problem is fixed now. The relay was bad. I also have a short in my steering collum which causes the horn to sound when making left turns :-(


Thanks for your help,

-Gööney0
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom