Welcome to the Corvette Forums at the Corvette Action Center!

'84 Wont start! Hayulp!

Z

ZackSchumann

Guest
My '84 Vette just wont start. It reads "12" right now but it used to read "21". the 21 went away a while ago and was running fine untill just recently. I have replaced the ECM (less the PROM), the coil, all of the distributor components (less the little condensor looking thing on the side) plugs and wires and it still reads "12" and will not start!! It has no spark whatsoever and is getting absolutley no gas pressure even though the feul pump was also recently replaced. I have no idea what to do besides let a shop have me sign my bank account over to them.

I love my car but this just sucks!
 
S

ssvett

Guest
Code 12 is what it should be reading if there are no codes. I'm not sure how the wiring is on an 84 compared to an 82, but I had one here that was just giving me fits. It turned out being a fuse that was at the battery in a fuse holder. It fed the fuel pump and ignition. As soon as we repalce the fuse and the fuse holder all is well............Steve
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
Hmmm no Start

Ok... do you have power to the coil? Big red wire to the side of the Distributor cap that's the first thing to check. Do you own a test light? ( the 12volt type that looks like a little pick?)

2nd) check the fuel pump fuse in the fuse box Labeled FP ( oddly enough ) bottom row 2nd from right AND the fuse labeled CRANK 5 amp AND ECM Ign.

3rd) have you inspected the fuseable links by the Batt compartment? If one of these is Charbroiled that could be the problem.

Let me know what your test results are

Mike
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
The little condenser thing is the filter for the tach!
 
S

Stingray

Guest
ssvett said:
Code 12 is what it should be reading if there are no codes. I'm not sure how the wiring is on an 84 compared to an 82, but I had one here that was just giving me fits. It turned out being a fuse that was at the battery in a fuse holder. It fed the fuel pump and ignition. As soon as we repalce the fuse and the fuse holder all is well............Steve

Steve's got the ticket :beer
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom