Welcome to the Corvette Forums at the Corvette Action Center!

88 Dash & Cruise.. and MAF issues

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
So here's a question for all you 85-89 Automatic owners
In the TACH window do you have the over drive indicator? I think I have a stick cluster in my auto car.

I've found my drive transistors blown for the cruise so I'm trying to find some generic replacements.... more news to follow.

I had my throttle plate bushed for $100.00 which took out all the slop, and got rid of my air leak, however my idle did not clear up, and my car still pinged under heavy acceleration ( No codes )


I did however unplug my MAF sensor and the car runs like a bat outa ( some very hot place down below )

No ping, great idle etc.

So any comments, thoughts from the gallery?

Mike
God Bless America!
 

Ken

Gone but not forgotten
Joined
Jan 30, 2001
Messages
8,237
Location
Hermosa Beach, CA
Corvette
1987 Z51 Silver Coupe
vigman said:
I did however unplug my MAF sensor and the car runs like a bat outa ( some very hot place down below )

Let me guess, a bat outta HELL, right? :L

Seriously though Vig, if you unplugged the MAF and it ran better, something is wrong. It shouldn't run worth a damn.

Sorry but this old brain ain't functioning too well yet today so I can't help ya diagnose it right now. I'll see if I can find something later, but maybe by then someone else will have an answer for you. ;)

Good luck!

_Ken
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom