Welcome to the Corvette Forums at the Corvette Action Center!

92- C4 350 v8 LT1 with and automatic - I have no blinkers, no reverse lights, I have brake lights, running lights and er

Whitevette92

New member
Joined
Oct 25, 2018
Messages
3
Location
New York
Corvette
92 white C4 Ragtop
Hi Folks,

I have a 92- C4 350 v8 LT1 with and automatic - I have no blinkers, no reverse lights, I have brake lights, running lights and er flashers.
If I replace the blown blue blinker fuse blinkers work till I put the car in reverse and then the fuse pops AGAIN.
Any thoughts?

Thx
John
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
Yep,I have some thoughts,It takes a big,Big,BIG Dog to weigh a Ton, And a Hell of allot Bigger Cat to whip him!:thumb

As far as your problem,Check the reverse lamp switch and reverse lamp sockets and wiring for a direct short.:beer
 

Whitevette92

New member
Joined
Oct 25, 2018
Messages
3
Location
New York
Corvette
92 white C4 Ragtop
Hi Folks,

Fixed it, one of the reverse lights was blown. After replacing the reverse lights and fuse for reverse and blinkers everything works great so far. Thx for the tips

John
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom