Welcome to the Corvette Forums at the Corvette Action Center!

AC blowing COLD AND HOT...

XLR8

Gone but not forgotten
Joined
Jun 23, 2004
Messages
6,662
Location
Mississippi Gulf Coast
Corvette
2003 AE Convertible, 1998 LCRM Convertible
... at the same time

I've noticed lately that my AC doesn't seem to be cooling as well. I can't remember if I first noticed it prior to the AC head unit replacement or afterward.

Then this afternoon I discovered that the AC is blowing COLD and HOT air through the vents at the same time. :confused The driver's side vents were blowing cold air while the passenger side vents were blowing hot. Changed the setting on the Passenger side contoller but it didn't alter the temp at all.

Ideas?

:w Jane Ann

C5InteriorPhotoGIF_C.gif
 

wishuwerehere82

Well-known member
Joined
Sep 6, 2003
Messages
2,314
Location
Rochester, NY
Corvette
Red '82 Coupe,Sebring Silver '98 Coupe
Woops!
I think you better take it back. They may have forgotten to plug in the connection to the head unit, or it may be defective.
Sometimes things happen when they do so many things at once.
:w
 

XLR8

Gone but not forgotten
Joined
Jun 23, 2004
Messages
6,662
Location
Mississippi Gulf Coast
Corvette
2003 AE Convertible, 1998 LCRM Convertible
Woops!
I think you better take it back. They may have forgotten to plug in the connection to the head unit, or it may be defective.
Sometimes things happen when they do so many things at once.
:w

Hey Pete... how you doin'?

I wondered if it would be a problem running the AC until I can get it back to Kevin? Unfortunately I didn't notice it until 7 this evening and his shop is closed for the weekend. And because of my schedule next week I can't take it in until Friday. :ugh

Thanks for the reply.

:w Jane Ann
 

wishuwerehere82

Well-known member
Joined
Sep 6, 2003
Messages
2,314
Location
Rochester, NY
Corvette
Red '82 Coupe,Sebring Silver '98 Coupe
Hey JAG, I'm doin good.

I forgot you actually use A/C this time of year. We're just getting to the point we can open the window around here.:L Just a little bit.
Can you regulate your temp on the drivers side? The pass. side will probably blow hot no matter what you do. You could close the vents down flat to close them off or point them off to the side so they don't blow on you.
I don't think you will hurt anything, but you could turn off the compressor if you're worried about it.
:w
 

tstar

Well-known member
Joined
Jul 5, 2006
Messages
52
Location
Central PA
Corvette
1999 Pewter Coupe
Sounds like a classic case of the actuator blues! Your passenger actuator is on the fritz... You can try to power cyle it by pulling the fuses or battery cable. When power is re-interduced to the system the actuators are supposed to cycle through thier entire travle range and re-calibrate. If that doesn't fix it you' ll probably have to replace it... alot of guys fix the driver's side but usually just R&R the Passneger side, mainly cause it's a b*tch to take out!

You should be setting a code as well, have you checked?

If you're getting error codes B0367 and/or B0446 the passenger side actuator is either out of range or not responding at all to the HVAC Control Module...

 

tstar

Well-known member
Joined
Jul 5, 2006
Messages
52
Location
Central PA
Corvette
1999 Pewter Coupe

bradfordsvettes

Well-known member
Joined
Mar 28, 2001
Messages
549
Location
Boston, MA area
Corvette
jewel blue 61.cranberry 69 t-top.black rose 92
I have also seen this in other GM model cars the evaporator is not cooling correctly because of the low charge it is worth a check if the head is ok only my 2 cents Steve
 

tstar

Well-known member
Joined
Jul 5, 2006
Messages
52
Location
Central PA
Corvette
1999 Pewter Coupe
I have also seen this in other GM model cars the evaporator is not cooling correctly because of the low charge it is worth a check if the head is ok only my 2 cents Steve
Yeah I agree! Deffinitly a first check! Good info guys, first I've heard of a low charge giving this symptom! ;shrug
 

jrose7004

Well-known member
Joined
Aug 5, 2004
Messages
8,712
Location
Oklahoma City, OK
Corvette
10 Grand Sport Coupe Artic White
Mine would do that annually the first time I would use the air, I would charge it and it would go away. Finally I took it to an auto air shop and they found a leak and fxed it.
 

XLR8

Gone but not forgotten
Joined
Jun 23, 2004
Messages
6,662
Location
Mississippi Gulf Coast
Corvette
2003 AE Convertible, 1998 LCRM Convertible
I appreciate the responses... due to a minor little crisis yesterday, I wasn't able to check codes or disconnects, etc... and I'm working this week until Friday. Of course I bet everyone can guess where I'll be Friday. ;)

Thanks again!
:w Jane Ann
 

XLR8

Gone but not forgotten
Joined
Jun 23, 2004
Messages
6,662
Location
Mississippi Gulf Coast
Corvette
2003 AE Convertible, 1998 LCRM Convertible
Update:

I checked for codes - no HVAC or actuator codes at all.

Kevin and I played with the passenger controller and could never get any responses from it. We also pulled the battery cable and left it off for awhile, but when we replaced it and restarted everything the issue was still there.

Kevin has ordered a new AC head unit in case the one we recently installed was bad. It didn't come in today, but he promises it for tomorrow.

We're also replacing the brake booster and the RF wheel speed sensor which started throwing codes yesterday.

I'll post more info after we replace the head unit.
:w Jane Ann
 

XLR8

Gone but not forgotten
Joined
Jun 23, 2004
Messages
6,662
Location
Mississippi Gulf Coast
Corvette
2003 AE Convertible, 1998 LCRM Convertible
:eyerole Replaced the head unit...still no go. Pulled actuator - my dash is in pieces everywhere - the actuator gear is cracked...Kevin just called the parts house. They don't have another one.:eyerole Glory be - they just called back and they DO HAVE ONE!

Give me patience. :mad

One good thing - I've taken some photos so I'll have some new ones to post tonight.
 

tstar

Well-known member
Joined
Jul 5, 2006
Messages
52
Location
Central PA
Corvette
1999 Pewter Coupe
I'm very surprised that didn't throw a code for the actuator being out of range...
 

XLR8

Gone but not forgotten
Joined
Jun 23, 2004
Messages
6,662
Location
Mississippi Gulf Coast
Corvette
2003 AE Convertible, 1998 LCRM Convertible
I'm very surprised that didn't throw a code for the actuator being out of range...
It surprised me too. I thought I was in the clear with the actuator when there were no codes. ;shrug


Ahh, cracked actuator gear. That's a good one for the old memory vault.

I tried to take a decent photo of the actuator interior showing the cracked gear but the photo came out blurred. This was the best I could get.

HPIM1411_3.jpg



And it's scary to see your Vette looking like this 2 days before a ~500 mile roadtrip! :eek:hnoes

HPIM1408_2.jpg
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom