Welcome to the Corvette Forums at the Corvette Action Center!

C4 A/C blower motor

V

Vrotate

Guest
Has anyone every had any trouble with thier blower motor only working on HI? I have the non-digital A/C cluster. I replaced the switch, but that wasn't the problem.
 

JonM

Well-known member
Joined
Mar 12, 2002
Messages
2,421
Location
East Haven, CT- USA
Corvette
84 Coupe
If it only runs on high, it is most likely the resistors located on the a/c plenum. (has yellow, dk blu, lt blu, and tan wires)
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
I'm resisting

So you have 3 diffrent hunks of Ni-chrome wire ( read resistors ) that reduce the current available to the motor....

I leg is common...

the 3 other ones are the different resistor outputs....

I DO find it ODD that all 3 would go out at the same time....

So break out the OHM meter and check it out..pull the resistor out of the air plenum and give it a look!


Vig!
 
V

Vrotate

Guest
Thanks Vig, I was going to start testing the wiring, but didn't have a wiring diagram. I had now idea how it worked.


Thanks a lot!

Vrotate
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
WOOF

Your welcome.. If you get stuck.. Ive got the shop manuals!

Vig!
 
V

Vrotate

Guest
Vig, Resisting Persisted

Thanks for the help everyone, the problem was the relay contacts. Gave them a little cleaning, bent the connection a little... Everything works!!!

Vig, where do you get your wiring diagrams? I would love to have em'

Vrotate
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
GM

They are the shop manuals.....

E bay!



Vig!
 
1

1stiff84

Guest
Another Blower Motor Problem

Dear All,

I am also experiencing a blower-related problem where the blower only directs air to the windshield and floor simultaneously, regardless of setting or fan speed.
Any suggestions?


Thank You,

1stiff84
 
V

Vrotate

Guest
Electronic or manual AC. Can you hear the 'directing door' move when you switch between settings, such as Vent and defrost.

You might want to just check your linkage cable; is what I'm getting at. (Behind the A/C controls) If it is a manual. I can't remember how the electric controls move the door, servo maybe?

Ask Vig, he is the man!!!

Vrotate
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
Door's open on suck!

So the controller ( manual ) has a vac switch on the back which opens, block's or closes vents VAC paths as the case may be.

There is a single line that comes from under the hood ( various source points from year to year) Coming from MANIFOLD vac.

It's a HARD plastic line.. about 1/8 inch in diameter...coming through the firewall.

Typically there is an inline filter ( which is known to FAIL) before it hits the controller.


Now if you have AUTO climate control... THAT box is against the interior firewall 1/2 between the TOP of the brake & accelerator pedals... and is a PAIN to get to.


First...locate this line... and see if it sucks under the dash.


Vig!
 
1

1stiff84

Guest
Vig and JonM

Thanks for your help. I bypassed the filter and all is well. Looks like I'll be hunting for a filter.

Happy Motoring,

1stiff84
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom