Welcome to the Corvette Forums at the Corvette Action Center!

car does not like hi-test gas

E

Eagle85C4

Guest
weird problem...anytime you give it the gas while moving the SES light would come on...code said bad knock sensor, so I replaced it. Now if I run 93 octane while crusing the light comes on with same code....but if I run 87 or 89 the light does not come on. I have replaced the O2 sensor as well. Any thoughts as to why it does not like 93?
 
S

Shadowing1985v

Guest
umm, i really have no clue

but maybe your ICM is going out

take it off and take it to autozone or a auto place store and have them test it
 
D

drcorvette

Guest
Eagle85

Weird!!!!
I seem to have the same problem recently.
Get a Knock sensor code. Changed my Knock Sensor ... same thing only occurs when I open it up. Changed my Electronic Spark Control ... same problem.
Maybe next gas fill up I will drop from 94 octane to maybe 87 to see if that corrects problem.
Keep me informed as to what you find and I will do the same.

Gary
 
S

Shadowing1985v

Guest
yeah

my car does the same thing too i think


guy's it can either be your idle air flow

or your iCM i think

i own a 85
i havn't fixed the problem cause im working on other stuff atm

but im looking into it
i get code 43 alot
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom