Welcome to the Corvette Forums at the Corvette Action Center!

Carb Backfires

mmvette80

Well-known member
Joined
May 12, 2002
Messages
273
Location
Central NY
I just put a gm goodwrench 350 with a aftermarket cam in my 80 Vette. The problem is if i nail the gas the carb burbs and backfires. Any help out there?
 
H

Hijinx

Guest
Check first of all for manifold vacuum leaks. Second, check your timing. Third use a vacuum gauge to set idle. One of these should work.
 

mmvette80

Well-known member
Joined
May 12, 2002
Messages
273
Location
Central NY
"carb backfires"

Ive checked for vacuum leaks and have set the timing to 12 deg. after. I have 15lbs of vacuum. The car is running like hell.
 

mmvette80

Well-known member
Joined
May 12, 2002
Messages
273
Location
Central NY
I have the timing set at 12 degrees Before. I checked all the valve lash again. I found the problem, the distributor cap!!!! The car runs mint. I also installed the 700R4 from Bowtie Overdrives. The first gear is amazing.
 

Buckskin7T7V

Well-known member
Joined
May 18, 2001
Messages
144
Location
Ca US
Corvette
1977 Buckskin
I had the same problem on my 77. Disconnected the EGR and the problem went away.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom