Welcome to the Corvette Forums at the Corvette Action Center!

Check Gauges Light

RichLee010

Member
Joined
Sep 25, 2006
Messages
6
Location
Ohio
Corvette
1990 White Convertible
I'm sorry but I posted this forum in the wrong place. I new to this and I put it under ZR-1. I just have a regular 90 Convertible.

I have a 90 convertible and my check gauges light just came on and is staying on. It use to flicker on occasion but would never stay on solid. The gauges are all working and are in the same "readings" as they have always been, hot and cold. The only thing I did was replace the Battery about 1 month ago. But as I say the Check Gauges lite started staying on solid about 1 week ago. I tested the Alternator and it's working fine. Any Suggestions??
Thanks,
Rich
 

bobder41

Member
Joined
Oct 19, 2005
Messages
8
Location
georgia
Corvette
1990 coupe l98
My 90 L did the same thing. All of my gauges are reading fine but the light came on. I do not drive mine much 50k miles but one day it came on and would come on 15 min after starting the car for several occasions. I had my alt ck and it was OK, temps ck and OK. Pulled and reinstalled the battery.
Called a corvette buddy and per him replaced the water temp and oil pressure sensors.
After all of that the light has not come on again for the last 500 miles. I only wish I knew what I did to fix it.
I did find out the light is controlled by a control module and the oil pressure sw.
I hope this gives you a place to start.
Bob
 

RichLee010

Member
Joined
Sep 25, 2006
Messages
6
Location
Ohio
Corvette
1990 White Convertible
Thanks This is the best advice I've gotten so far. I took it to a so called "vette specialist" and after a lot of looking under the hood, checking this and that, he finaly just ho-hummed and said "if the gauges look good don't worry about it. You gave my everyday mechanic a great place to start looking
Thanks Again,
Rich

My 90 L did the same thing. All of my gauges are reading fine but the light came on. I do not drive mine much 50k miles but one day it came on and would come on 15 min after starting the car for several occasions. I had my alt ck and it was OK, temps ck and OK. Pulled and reinstalled the battery.
Called a corvette buddy and per him replaced the water temp and oil pressure sensors.
After all of that the light has not come on again for the last 500 miles. I only wish I knew what I did to fix it.
I did find out the light is controlled by a control module and the oil pressure sw.
I hope this gives you a place to start.
Bob
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom