Welcome to the Corvette Forums at the Corvette Action Center!

Electric Quirk

Joined
Mar 27, 2003
Messages
3,671
Location
Mustang, OK
Corvette
'13 427 60th vert - '21 Silver Flare Coupe - CTS V Wagon(4-door Vette)
Greetings.
Got one for you C6 experts: Yesterday, the Nav/Radio panel went blank and none of the controls on it worked.
While driving to a local Chevy dealer to talk '08 Vettes of all things, I had the Nav system displaying and the radio on low. Next thing I notice, the screen is blank. I still hear the radio but I can't adjust the volume. Can't switch modes, can't open the CD/DVD access, nothing works and it will not turn off either.
Drive on to the dealer - service department is closed, it's Saturday. Shut off the car and tried accessory mode - still blank and nothing works except the radio is still playing.
I figure I'll make an appointment for next week some time.
After spending 30 minutes at the dealer, crank the car up and, presto, the Nav display comes back and everything is working again. I made 2 more stops before going home and it worked the rest of the day.

Loose wire, loose fuse? Where should I start looking in case this happens again?
 

Hib Halverson

Technical Writer for Internet & Print Media
Joined
Jan 10, 2001
Messages
13,453
Location
CenCoast CA
Corvette
71 04 12 19
Hey Tuna!
First let me say that the C6 entertainment and nav system is "nighmarishly" complex. You oughta see the schematics in the FSM!
Since the problem is random and, when it occurs, the radio still works, I'd say it's probably not a power issue, ie: loose wire or loose fuse but it never hurts to check fuses and the ones you need to check relate to entertainment in nav. Their locations are in the FSM and probably your owner's manual.

If you have a scan tester which supports C6, first thing to do would be to run diagnostic systems check in the FSM then see if there are any codes set which relate to the entertainment or nav systems. If they're codes set, I'd follow the FSM info to solve them.

If you don't have a scan tester, take the car to a service facility which has one. There is no way to display DTCs on the IP like there was with C5.

Or....buy a darn road atlas.
:)
 
Joined
Mar 27, 2003
Messages
3,671
Location
Mustang, OK
Corvette
'13 427 60th vert - '21 Silver Flare Coupe - CTS V Wagon(4-door Vette)
I've ordered a set of manuals for it and should be in any day. I'm just not good at reading electrical schematics. No scan tester at my house, at least not one that understands a C6. It's working today, so I'll just wait until it fails again or it's in the shop, then I have the service guys check it.

Thanks.
 

paulj1x

Member
Joined
Aug 10, 2003
Messages
9
Location
San Diego, CA
Corvette
1999 Torch Red Coupe
Anything unusual at the time of failure? Hot day? Bump in the road? Any type of electrical noise?

paul
 
Joined
Mar 27, 2003
Messages
3,671
Location
Mustang, OK
Corvette
'13 427 60th vert - '21 Silver Flare Coupe - CTS V Wagon(4-door Vette)
Anything unusual at the time of failure? Hot day? Bump in the road? Any type of electrical noise?

paul

No idea. Didn't notice that it had gone blank. The wife and I were talking with the radio in the background and I wasn't paying any attention to the Nav screen, so I have no idea when it went blank.

It was 80 degrees with high humidity and it started raining after the incident.

I'll just have to keep a watch on it and since the wife drives it to work everyday now, I'm sure she'll tell me if it happens again.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom