Welcome to the Corvette Forums at the Corvette Action Center!

Electrical Nightmare

74bigblock

Well-known member
Joined
Sep 30, 2003
Messages
1,163
Location
Barrington, IL
Corvette
2008 Z06
Yeah so wouldn't it figure that the 1st time I take the vette out for a real cruise all year... I end up getting trailered home on a flat bed?

Drove about 30 miles to a cruise night... headed on back... everything was running fine. Stopped off for some ice-cream... everything fine. Stopped for some gas...

Not even a click from the ignition. Battery barely had enough power to light up the parking lights or honk the horn. :puke

tried jumping it... nothing. Tow Truck came... tried hooking her up to the rig... charged for 10 min, and it barely even clicked (but the lights worked while plugged in). The jumper cables were hot when we pulled em off... so I have a short somewhere. But where, and how so suddenly?

;help
 
T

TMPJoe

Guest
Things to check:

Charge battery completely with a good charger... see how it holds current or take it to be tested somewhere.. could be a dead cell .... happens

if its charged and it starts check output from alternator.. should be 13.7-14.5 volts

after that check cables... especially running to starter....
 

Phill

Well-known member
Joined
Apr 20, 2007
Messages
216
Location
s.florida
Corvette
1979 Blk L48
I had a similar problem on my 79, would kill the battery in a few hours. if battery and alternator are good check your wiring like mentioned. i found several if not all the engine and starter wireharness cut and twisted together. but i believe my problem was the wipermotor and ac blower motor ground where connected to positive. get yourself some manuals and a wiring diagram these should help a great deal. good luck.
 

LVMYVT76

Well-known member
Joined
Apr 21, 2006
Messages
664
Location
springfield, mo
Corvette
1976 medium blue
Sounds like a dead cell to me. I had the same problems before and it turned out to be the battery.
 

MikeMc71

Well-known member
Joined
Apr 30, 2007
Messages
100
Location
Tucson, Arizona
Corvette
1970 Roadster, 1971 LT-1, 1971 Coupe
I have also seen this with just dirty cables at the battery. Good Luck!
 

USNA1969

Well-known member
Joined
Sep 12, 2005
Messages
93
Location
Maryland
Corvette
1972 Big Block/4-Speed
I had a similar problem. It turned out to be a loose connection at the battery.
Good luck.
 

74bigblock

Well-known member
Joined
Sep 30, 2003
Messages
1,163
Location
Barrington, IL
Corvette
2008 Z06
I'm gonna pull the battery tonight, clean off the terminals and give it a good charge. If she won't take it.... problem solved! If she does take it...

:bash
 

Vetsvette2002

Well-known member
Joined
Nov 20, 2002
Messages
198
Location
Willowbrook, IL
Corvette
67 convt. L79 Marina Blue
If the battery terminals and cables are OK, and the battery accepts and holds a charge, and you still have a no power start condition, disconnect the two bulkhead connectors on the firewall and clean the terminals. A little di-electric grease will help to retard corosion.

Don
 

74bigblock

Well-known member
Joined
Sep 30, 2003
Messages
1,163
Location
Barrington, IL
Corvette
2008 Z06
No charge... she wouldn't even hold 1 amp! Pretty big for a paperweight.

Ran out and picked up an Optima 75/25. She fired right up!


:W :W Look out Northern Illinois!!!​
 
T

TMPJoe

Guest
No charge... she wouldn't even hold 1 amp! Pretty big for a paperweight.​


Ran out and picked up an Optima 75/25. She fired right up!​



:W :W Look out Northern Illinois!!!​


Thats terrific... where is that EASY BUTTON anyway:w
 

74bigblock

Well-known member
Joined
Sep 30, 2003
Messages
1,163
Location
Barrington, IL
Corvette
2008 Z06
Did ya get the brakes fixed?
All go, and no stop are a bad combination!:L

They aren't perfect.... still getting a little squeal, but they aren't spongy anymore!!

Too bad it's 98 and humid out... I'd take her to work!
 

fine69

Well-known member
Joined
Dec 12, 2004
Messages
975
Location
Maryland / D.C.
Corvette
'69 Convertible Vette; '72 Z28 Camaro Rally Sport
No charge... she wouldn't even hold 1 amp! Pretty big for a paperweight.​


Ran out and picked up an Optima 75/25. She fired right up!​



:W :W Look out Northern Illinois!!!​

Great battery. I have the Optima yellow top. Never had a problem.
 

LVMYVT76

Well-known member
Joined
Apr 21, 2006
Messages
664
Location
springfield, mo
Corvette
1976 medium blue
It sometimes seems that setting all winter, the battery looses charge from not being driven or run and starts getting a dead cell. If you disconnect the battery, thus taking all discharge off of it, the battery will hold up better. Now, I was using a delco battery when mine was acting this way, I changed to a different brand and kept it disconnected and it holds up better. Glad you found your problem!
 

74bigblock

Well-known member
Joined
Sep 30, 2003
Messages
1,163
Location
Barrington, IL
Corvette
2008 Z06
It sometimes seems that setting all winter, the battery looses charge from not being driven or run and starts getting a dead cell. If you disconnect the battery, thus taking all discharge off of it, the battery will hold up better. Now, I was using a delco battery when mine was acting this way, I changed to a different brand and kept it disconnected and it holds up better. Glad you found your problem!

I use a quick disconnect on the negative terminal... any time I shut off the car, I unscrew the disconnect so there is no power drain... it also is a theft deterant. The battery didn't drain on it's own... something in it went Kaput! It was 4 years old and a cheapo battery anyway.
 

LanceB

Well-known member
Joined
Jul 18, 2003
Messages
455
Location
Louisville
Corvette
1981
AAA

I use AAA, they actually bring batteries to you now. It is actually a great service to have, especially when you drive a 30 year old car. Paid a little bit for it, but better than taking off work all day to change a battery. I had the same problem when I went to get lunch from work one day. New battery, everything fine.

On another note, it was over 100 degrees today, and a co-worker of mines battery BLEW UP when he started his Chevy Blazer. He still didn't have it working when I left work today, even after replacing the battery (I offered a ride, but he already had one). I have never seen the top blow off a battery before.
 
T

TMPJoe

Guest
i have a friend who now has one eye from a battery exploding in his face

it happens....
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom