Welcome to the Corvette Forums at the Corvette Action Center!

Hard Starting after Engine cools

johns81

Active member
Joined
Nov 11, 2005
Messages
36
Location
Indianapolis
Corvette
1981 Beige/bronze
Hello everyone. Looking for ideas on what may be going on. All if a sudden, my 1981 has a hard time starting up when the engine is cool/cold. Starts right up when the engine is warm. Just starting happening over the past week. Took it to the locale chevy dealer, they kept if for 2 days and said the timing was off and the Carb. need to be adjusted. Fast forward to the next day, hard starting returned. Runs great when it starts. Any suggestions or comments will be greatly appreciated. Chevy service has done a great job in the past.

HELP!!
 

bill81vette

Moderator
Joined
Jan 17, 2004
Messages
4,315
Location
Troy,NY
Corvette
1981 dark blue metallic
check your fuel pump.could be getting weak.
 

johns81

Active member
Joined
Nov 11, 2005
Messages
36
Location
Indianapolis
Corvette
1981 Beige/bronze
I had the same problem and I changed the fuel pump and back to normal.
Thank you for responding! I think this car has 2 fuel pumps, electrical in the tank and mechanical in the front. Which one did you replace? Thanks!
 

bill81vette

Moderator
Joined
Jan 17, 2004
Messages
4,315
Location
Troy,NY
Corvette
1981 dark blue metallic
there is not a pump in the tank.that started the following year with the crossfire,82.
81's were still mechanical.
good luck!!!
 

johns81

Active member
Joined
Nov 11, 2005
Messages
36
Location
Indianapolis
Corvette
1981 Beige/bronze
Hello again, Well my mechanic made a couple of adjustments to the carb, checked the fuel pump pressure and said all is well. Cruising along at about 45mph one day, engine shut down. Was able to get it started, made it home. Next day, would not start at all. Mechanic replaced the fuel pump and I was back on the road. Until 2 days later, car shut off again. It would start long enough to travel about 2-3 blocks. Towing it back to the mechanic. Frustrating as heck. Anybody ever had this experience? Possible defective fuel pump. It was manufactured by Carter. Please share any information that might be helpful to me. Wife is ready to dump it. I'm not to do so yet.

Thanks for any replies

John
 

Tom Bryant

Well-known member
Administrator
Joined
Nov 9, 2000
Messages
7,304
Location
Edgerton, Ohio, United States
Corvette
1959 black 270hp (9/2/69) 1981 Beige L81(10/20/80)
There is an old mechanics saying that most fuel problems are ignition. Could be the ignition module or coil failing. Did they scan it to see if the ECM threw any codes when it quit?

Tom
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom