Welcome to the Corvette Forums at the Corvette Action Center!

Headlights stay closed (but it's not the gears)

Rob Musquetier

Active member
Joined
Apr 3, 2006
Messages
41
Location
Netherlands
Corvette
1959, 1963 SWC, 1969 Conv, 1999 Coupe
Hi all,

Normally I reside in the C1/C2 forums but lately I have a C5 related problem with my 99 daily driver.

Appr. a year ago I had some trouble with the touth of my actuator gears comming off so I replaced both the left and right gears for the known brass once which solved all the open/close problems at that time.

Lately my driver side light often don't open (started with once in a while and is now nearly everytime).

The lights of the unit are on so I recon the light switch is working...

When I take the unit out it always seems to work but when assembled back in the car it seems to work for some time but quickly starts refusing to open...

Is this also a common problem and what is the advised solution?

I'm nearly at a point that I'm gonna spend $299 on a new left door actuator as I do need the lights during my morning drive into the office (at 6:30am) because it is getting darker each day...

Please advise or let me know other known issues with this assembly!

thanks,
Rob Musquetier
webmaster/developer http://www.c1registry.com
developer http://www.c2registry.org
webmaster/developer http://www.c3registry.org
 

Rob Musquetier

Active member
Joined
Apr 3, 2006
Messages
41
Location
Netherlands
Corvette
1959, 1963 SWC, 1969 Conv, 1999 Coupe
I would check your headlight switch as it controls both low beam and headlight door operation.

If the switch is the cause would my light than be lighted anyway?

thanks,
Rob.
 

Larry's Yellow Rdstr

Well-known member
Joined
Oct 19, 2002
Messages
304
Location
Redlands, Ca.
Corvette
05 black cpe-Porsche GT3
Could be Rob, I'm always amazed at electrical gremlins. The switch is probably cheaper than your other option.
Good luck and keep the wave.
 

Rob Musquetier

Active member
Joined
Apr 3, 2006
Messages
41
Location
Netherlands
Corvette
1959, 1963 SWC, 1969 Conv, 1999 Coupe
Could be Rob, I'm always amazed at electrical gremlins. The switch is probably cheaper than your other option.
Good luck and keep the wave.

That's a valid point you are making. I understood from some extensive searching also the control module could be the fault. I'm still puzzled due to the fact when it is build out it seams to work just fine, only fitted in the car it stops opening after a while...

:-(
 
Joined
Nov 12, 2002
Messages
346
Location
Lebanon, Mo.
Corvette
2013 60th Anniversary Grand Sport
Rob,

Did you find the problem with your headlight? My 98 just started doing the same thing. Looking for any help with the problem.

Thanks,
Mike
 

FLIR_man

Well-known member
Joined
Sep 12, 2002
Messages
89
Location
Winter Park, Fl USA
Corvette
2000 coupe Metallic Blue
I had a similar problem on my 00 and found that I did not have enough clearance between the fender and the headlight cover. The problem was intermittent because of temperature changes but I finally noticed the pain rub evidence.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Advertise with the Corvette Action Center!

Double Your Chances!

Our Partners

Top Bottom