Welcome to the Corvette Forums at the Corvette Action Center!

help, should I clean optispark ?

misterKTM

Well-known member
Joined
Nov 22, 2001
Messages
76
Location
colton, oregon, usa
Corvette
'93 Black 6 Speed
While doing an oil change on my wifes '94 T-A (LT-1), I noticed the water pump starting to go south. I went ahead and pulled it out, and sure enough the seal is toasted in the back. It's been leaking for a couple weeks looks like. Now of course I start quizing the wife about things (I rarely drive the car - the Vette is mine !!) She tells me the low engine coolant light has been intermitently coming on.....And she's recently noticed an occasional rough idle and stumble a few times. SOOO, the question is, while I have the water pump off, should I take the optispark off, disassemble and clean it up ? I know these things have a history of failure. The previous owner of my Corvette had just replace the optispark on it before I bought it. That was at about 50,000 miles. The T/A has 45,000 - So I'm thinking it might be about ready to go. Is it worth cleaning these things ? Do they start missing here and there before they totally go out ? Any suggestions - comments appreciated.

Thanks,

Rob
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
REPLACE IT

Do not mess around.. it will be a headache

Just nail it now.. you have 95% of the work done already.


Mike
 

Radar

Well-known member
Joined
Oct 23, 2001
Messages
200
Location
Oconomowoc, WI
Corvette
1989 Medium Blue Metalic Convertible
I also vote for replacement. Corvette Fever has run articles on this topic.

radar
 

misterKTM

Well-known member
Joined
Nov 22, 2001
Messages
76
Location
colton, oregon, usa
Corvette
'93 Black 6 Speed
After further grilling of the wife, she says the rough running has happend mostly at cruise speeds and throttle positions. Never had a problem accellerating. It has just ran rough a few times 'coasting' down a hill or at cruise speed on the freeway type thing. Does this sound like a failing optispark ?? I know my Vette's only lasted 50K, is that about all they are good for ? Is it a known constant that every one of these things fail ? I see I have two suggestions to replace it, but I hate to spend $300 or $400 dollars on an ignition if I don't have to.
 
M

Moffitt

Guest
If the bearing is good, I vote for cleaning! Mine failed and I took it apart. It was very rusty and the bearing was terrible. I had another that the optics had failed in. I made one out of the two and it worked fine for the last two years. The trick is getting it apart (if it's a 94 and earlier unit). The cap and rotor comes off easily, the trigger wheel is another story! I removed the optical unit screws and pushed the trigger wheel and optical sensor out as a unit. Be careful not to bend the trigger wheel! I cleaned it well, icluding cleaning the sensor eyes with a Q tip, and pushed the wheel and sensor back into the bearing (once again, don't bend the trigger wheel). I used a small vice as a press. I looked high and low for a new bearing, it's a real odd-ball. Same with the seal! I sealed the unit with black RTV and vented it with the 95 and up GM vacuum harness. I drilled the hole in the cap with a die grinder and epoxied in the vent tube like the article in Corvette Fever detailed (issue, last spring sometime). If it's a 95 or later the trigger wheel is held on with tiny screws and makes it much easier to remove. Just make sure it is well sealed to prevent entry of moisture. The Opti gaskets are terrible and I eliminated them. There is nothing inside the unit that creates a clearence problem without them. The cap screws are kind of a pain to reach, I welded an old torqs screw to an old screwdriver. I don't think there is any reason not to clean an opti, the electronics are pretty much bullet proof, the rust flakes clogging the windows, sensor eyes getting dirty and rough bearings are what makes them act up. Make sure that the unit is splined correctly, it does not take much wear to allow the missing spline to be misskeyed. I would install just the opti and start the engine before installing the waterpump, if it runs OK you got it. I missed once and it ran like poop.
 
V

vettepilot

Guest
Been there done that, got the T-shirt. Got pretty good taking the water pump off for the third time, once to replace the pump, twice to take the opti-spark off. The second time for the opti-spark it got replaced. I highly recommend replacement on the first go. Time from beginning to driving again was only 1 1/2 hours. The real time consuming job is getting ALL the waterpump gasket material off the front of the block.
Good luck!
Stan
I remember an old joke about how great a mechanic a person was supposed to be. Goes like this:
Are you a good mechanic?
Yep.
How do you know?
Well I take my car apart and fix it every weekend.

Moral: If your good, you fix it once!
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
Amen BRO!

Do it right ... the first time, but we LOVE to say


Told YA SO!

Mike
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom