Welcome to the Corvette Forums at the Corvette Action Center!

Hood no-open blues ... AGAIN !

T

tonylong

Guest
Well I thought I fixed this problem several weeks ago when I adjusted the cable ends to allow less extension of the catches. Worked for a while.
Now the release pulls easily but no release. Any thoughts on the cure ?
Is this now a cable replacement issue, or is there an adjustment I can try ?
TIA
 

douglas foster

Well-known member
Joined
Aug 18, 2005
Messages
225
Location
minnesota usa
Corvette
1984 C4 Gold coupe, Z51, 4+3 manual, BBS rims,
father & son

If you haven't broke the cables, try adj. the lower bumper stops up a few threads. Also the hood catch springs could be weak, may have to replace.what I did if cable brakes, was attach a wire to each hood release, and ran enough wire from them so i could just pull each wire and latches would release. The wire hides next to each wiper. I tried the rod release by
the parts people but did not work very well.
 
T

tonylong

Guest
OK Problem identified. Doctor Dealer showed me it's the cable assembly. Seems the outer sheath has rotted away enough on the driver side to prevent the inside cable from actually pulling correctly. No Biggy, replace the cable assy.
Thanks to all for your responses.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom