Welcome to the Corvette Forums at the Corvette Action Center!

K&N induction system problem

J

jrizz1

Guest
I just installed the K&N induction system on my 2000. The problem I have is closing the hood. It seems the filter or air chamber are hitting the hood before it is fully down. This leaves the leading edge of the hood raised about 1/4 inch. Has anyone else had this problem? Is there a way to lower the system down a bit?
 

bwing

Well-known member
Joined
Oct 28, 2005
Messages
517
Location
California
Corvette
03 Z06,66 coupe(sold),99 Porsche Carrera(sold)
I have no experience with the K&N system (I installed a Vortech "Rammer") but it sounds like your air bridge may be what's causing your hood not to close entirely. Check to see if the air bridge is mounted correctly with the 2 rubber grommets on either side. Your K&N system may be causing it to be high. Hope this helps.
 

DocOhm

Well-known member
Joined
Mar 5, 2005
Messages
61
Location
Okla.
Corvette
2001 Coupe QuickSilver A4
I just installed the K&N induction system on my 2000. The problem I have is closing the hood. It seems the filter or air chamber are hitting the hood before it is fully down. This leaves the leading edge of the hood raised about 1/4 inch. Has anyone else had this problem? Is there a way to lower the system down a bit?
Something isn't right. I put mine on a year ago, no problems. It does rub a little on the insulator that is on the hood in that area. Is your radiator mount out of position?
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom