Welcome to the Corvette Forums at the Corvette Action Center!

no heat?

the water boy

Member
Joined
Jul 14, 2007
Messages
5
Location
washington pa.
Corvette
2001 coup dark blue
2001 coup. i have good ac, fan works fine, thermostat was replaced, i cant get any heat from the heater or defroster. any suggestions?
 
Joined
Jan 19, 2003
Messages
3,021
Location
5,800 feet above sea level
Corvette
2006 'Evil Stealth Black' Roadster
I'm confused. This is the middle of July. Are you really needing a heater and defroster in mid-summer? Assuming they were working, are you sure you'd be able to tell?
;shrug

-Patrick
 
Joined
Feb 26, 2004
Messages
67
Location
Greenville, Tx
Corvette
2006 MN6 Coupe
2001 coup. i have good ac, fan works fine, thermostat was replaced, i cant get any heat from the heater or defroster. any suggestions?
------
Have you checked to ensure that heated coolant is getting past the thermostat? (Check the temperature of the outlet hose as the engine warms -- it should get noticeably warmer from a cold start in short order this time of year.)
 

the water boy

Member
Joined
Jul 14, 2007
Messages
5
Location
washington pa.
Corvette
2001 coup dark blue
ok, if its the 2 hoses that are coming off the side of the thermostat housing, then yes they are getting hot. im assuming that there is a flap, or a door somewhere that isnt opening. this would either be caused by 1) door stuck, 2) whatwever controls this door not functioning. any input?
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom