Welcome to the Corvette Forums at the Corvette Action Center!

Oil pressure

D

Dcalebaugh

Guest
I know from searching that this issue has alot of posts so I will add mine. I just purchased my first vette a red 1986. All seems fine so far except the oil pressure readout on the dash stays at 80psi, running or not and never flucuates. Would this be a oil switch or oil sensor? The local gm dealer has both but I wasn't sure which one. Also if some one could maybe help with the location of the correct device I would appreciate it. I am still waiting for my parts book to arrive. Thanks in advance.

Dave
 

grumpyvette

Well-known member
Joined
Apr 17, 2001
Messages
841
Location
Loxahatchee, FL, Palm Beach co
its likely to be a bad sensor or perhapsthe connector on your wireings just not plugged in on the sensor (its next to your distributor on the drivers side slightly
 
S

Shadowing1985v

Guest
kewl

u are in luck my friend
i own a 85 and i had that same problem it read 80 all th etime no matter what,, umm my dad fixed it though when i was at work one day and i don't remember what he did though..wait i know there is a sensor on your oil line. can't reember wear though,, jeeze im not much of a help like i thought i would be. i think it might be next to your oil filter under your car . there might be a sensor there somewhere
 

Top

Well-known member
Joined
Mar 20, 2002
Messages
161
Location
Las Vegas, Nv
Corvette
1986 Convertible Dark Red Metallic
The oil pressure switch is by the distributor. Disconnect it and 'jump' the tan wire to ground. Turn the ignition on. The display should show zero. If it does replace the oil pressure switch. A defective switch with a bad ground would show '80' on the dash. If it still reads 80 you have a break somewhere in the tan wire to the cluster thru cavity C1, via the blukhead connector, cavity A2. I'm betting, I live in Vegas..:), that your wire is either loose or the pressure switch is bad.

Brost!! :beer
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
Top is CORRECT!

Mine however... was not connected properly

The connector is in a big rubber boot... most people MISS when connecting the connector.

So it's held captive between the boot & the connector ( crappy connection )



Vig!
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom