Welcome to the Corvette Forums at the Corvette Action Center!

rough running 82

hotshotzny

Well-known member
Joined
Jun 17, 2007
Messages
627
Location
ulster county ny
Corvette
bright red 1984 crossfire
;helpi have a 1982 vette with the crossfire fuel injection, here is my dilema, when i get in the car and start it up it takes off down the road like a raped ape, once i get maybe a mile down the road and stop at say a stop sign or red light it runs very rough on take off, sputtering and spitting like it is gagging for fuel, yet it does not idle rough, once i get rolling again it runs fine until i come to a stop again and it does not run well at slow speeds, i have drained the cruddy old fuel out of it, changed the fuel filter and O2 sensor realizing there are tons of 25 year old things in here that need to be changed i am hoping to at least know where to start so i can at least have it running a little better for now
 

wishuwerehere82

Well-known member
Joined
Sep 6, 2003
Messages
2,314
Location
Rochester, NY
Corvette
Red '82 Coupe,Sebring Silver '98 Coupe
The ECM opens the EGR valve at speeds over idle, then shuts it down again when the TPS voltage goes back to idle.
It sounds like your EGR valve is getting stuck open and isn't closed at idle.
If you put your fingers under the Valve and push up on the diaphragm, it will stall the engine at idle. Careful, it's hot!
It is probably rusted or has a piece of carbon stuck in it.

Or it could be the CTS (coolant temperature sensor) in the front of the intake manifold.
It monitors engine temperature and adjusts the fuel/air mixture. It starts off rich when the engine is cold, then leans the mixture as the engine comes up to operating temperature.
A lot of running problems are a result of the CTS getting old and not sending the proper voltage signal to the ECM. The old ones have a single wire connector, but the new ones have a 2 wire connection with one that goes to ground instead of grounding through the sensor to the manifold.
 

Buccaneer

Well-known member
Joined
Jun 17, 2007
Messages
124
Location
Gilbert, AZ.
Corvette
1982 Dark Claret Coupe - 383CI CFI
Just curious...at stone cold start, does the motor have a nice fast idle and then drop down or is it just a fast idle and rather erratic even when warm?
 

hotshotzny

Well-known member
Joined
Jun 17, 2007
Messages
627
Location
ulster county ny
Corvette
bright red 1984 crossfire
the engine idles like a champion all the time, never a sputter or anything, stone cold or at operating temp.
 

Buccaneer

Well-known member
Joined
Jun 17, 2007
Messages
124
Location
Gilbert, AZ.
Corvette
1982 Dark Claret Coupe - 383CI CFI
Other than what's already mentioned which is a good place to start, what's the FP set to? 14psi works best.
 

hotshotzny

Well-known member
Joined
Jun 17, 2007
Messages
627
Location
ulster county ny
Corvette
bright red 1984 crossfire
its getting better

well after replacing the cap,rotor,wires,plugs coil, egr valve, pcv valve, fuel filter and cts its actually starting to run pretty good, still has a little hesitation when i floor it and runs a little funny when its hot but compared to what it was it is 110% better, thanks for all the advice guys,

:beer
 

jdp6000

Well-known member
Joined
Aug 23, 2004
Messages
646
Location
Aurora, Ontario, Canada
Corvette
1982 CROSSFIRE
Spend the money and change the fuel pump to an 85. Fuel delivery will never be an issue after that. Response becomes instant.

Jim
 

Buccaneer

Well-known member
Joined
Jun 17, 2007
Messages
124
Location
Gilbert, AZ.
Corvette
1982 Dark Claret Coupe - 383CI CFI
Bump... Just checking, is your ride finished and running well now? What did you finally set the FP to?:eek:hnoes
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom