Welcome to the Corvette Forums at the Corvette Action Center!

Squealing from engine!

R

rubberman15

Guest
I have a '99 Coupe hatchback with an automatic & 65K miles. I have a bad squealing sound from the engine area. I took it to the dealer and they replaced the tensioners, guide and belt, but it is still going on. It does not make the sound when I start up or just idle, but when I am driving and I accelerate. It sounds like a belt, but that was also replaced. Speed also does not make any difference, but I notice it once I am over 30MPH (cold or warmed up). Dealer thinks it may be a component, but they are not sure. I am not getting and warning notices and there was nothing when they hooked it up to the computer.

This all started about 2000 miles ago.

Has anyone had a similar situation or have any ideas or thoughts?

Thanks in advance.
 

99WhiteC5Coupe

Well-known member
Joined
Jan 19, 2002
Messages
293
Location
Cincinnati, Ohio, USA
Corvette
1999 White Coupe
I have a '99 Coupe hatchback with an automatic & 65K miles. I have a bad squealing sound from the engine area. I took it to the dealer and they replaced the tensioners, guide and belt, but it is still going on. It does not make the sound when I start up or just idle, but when I am driving and I accelerate. It sounds like a belt, but that was also replaced. Speed also does not make any difference, but I notice it once I am over 30MPH (cold or warmed up). Dealer thinks it may be a component, but they are not sure. I am not getting and warning notices and there was nothing when they hooked it up to the computer.

This all started about 2000 miles ago.

Has anyone had a similar situation or have any ideas or thoughts?

Thanks in advance.


Hello,

I had a similar problem with my 1999 C5 coupe (white also......). The idler pulley (not the tensioner) under the alternator (there are two - the defective one is under the alternator) was defective and caused the squeal / squeak. There was a TSB which instructs the dealer to replace it with a revised / updated part which is stronger to resist crushing of the bearing race.

Here is the link for the TSB: http://corvetteactioncenter.com/kb/question.php?qstId=258

When the idler pulley was replaced according to the TSB, the noise in my car was eliminated.

I hope this helps - good luck.
 

silverbullit99

Well-known member
Joined
May 18, 2006
Messages
80
Location
Montreal, Canada
Corvette
1999 Silver
I have a 99 as well,, same noise. I had my belt replaced last week ,, no difference :( I read that it could be the crank pulley. That will be my next try. It makes noise while it's cold, but after driving for awhile it is much quietier..
 
C

c84/99y

Guest
hi guys, there is a service bulletin on the tensioners for both drive belts, you my want to look into this it may help
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom