Welcome to the Corvette Forums at the Corvette Action Center!

Starts eratic, runs rough, stalls

B

bdisanto

Guest
Got into my 87 Convertible, ( 42,000 miles) started it up like I have done a hundred times with no problem, tonight I backed out of my garage the car stalled, would not start for a few minutes, car turns over but nothing. When car does start, it stalls a few seconds after I stop giving it gas. Please Help!!!

Thanks

Ben
 

Ken

Gone but not forgotten
Joined
Jan 30, 2001
Messages
8,236
Location
Hermosa Beach, CA
Corvette
1987 Z51 Silver Coupe
It sounds like the fuel runs out- I pulled a code 34, can it be the MAF sensor...?

Circuit Description:
The Mass Air Flow (MAF) sensor measures the amount of air which passes through it. The ECM uses this information to determine the operating condition of the engine, to control fuel delivery.

The oil pressure switch or the ECM, through control of the fuel pump relay, will provide 12 volts for the MAF power relay which provides the 12 volts needed by the MAF sensor.

The ECM provides a current limiting 5V on the signal line (CKT 998). The MAF sensor then changes the signal by dropping the voltage so that with low air flow the ECM sees a low voltage and a high air flow will cause the ECM to see the near the 5 volt supply.

Code 34 indicates the ECM has seen low air flow less than 2.5 gm/sec (low voltage) for one second when:
  • Engine is first started

    OR
  • RPM above 600
  • TPS above 6%. To obtain 6%, the engine has to be running at about 2300 rpm in neutral.

  • A Code 34 may be caused by an engine that exhibits a low, rough, unstable or incorrect idle problem. If this condition exists, disconnect the MAF sensor. If the unstable idle still exists, see symptoms in Section "B" of the Service Manual. If the idle improved with the sensor disconnected, replace it. Code 34 could also result from a dirty or misadjusted throttle body. Refer to Section "C2" of the Service Manual for minimum idle speed adjustment.
  • This test will determine if the conditions still exist to set a code or if the problem is intermittent:
    With the MAF sensor disconnected, the ECM should see a high voltage and set a Code 33. If a Code 34 resets, then the wiring or the ECM is at fault.

Clear as mud now? :L


I hope this helps you; as you may already be aware, I'm having my own fun with Code 33 on my new hot rod engine. ;)

_ken :w
 
S

Shadowing1985v

Guest
he only has 42K miles on it

i think its a vacume line, they can come off easy some times

usually when u get code 33 it means your not in time
i had it and thats hoi cleared it

does your car sound like its missing cyclinders
we need more infro


if your alt is bad or your battery

it will do what u described
see what your volts are reading on that

i doughts its a sensor,, i think most sensors last till 100K miles


but i think peopl ehave replaced them aroudn 50K miles but ususally on like 93's and up
 
B

bdisanto

Guest
Thanks

Thanks guys, I have a new battery, new alternator, new fuel filter, checked all the vacuum lines, and fuel pressure, everything ok. I picked up a new MAF relay this morning, ( only $11.00) I'll try that, getting desperate, car still starts, idles, rev it up, it stalls and will not start for a while.
 
S

Shadowing1985v

Guest
o i know what, a bad coil

sometimes
a bad coil will work when its cold

and then when the coil warms up it stops working
 
S

Shadowing1985v

Guest
maybe a cloged cat

check your exhaust
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom