Welcome to the Corvette Forums at the Corvette Action Center!

Vacuum Tank

L

LarryK 87

Guest
did all years C-4 have the vacuum tank? per the Helms manual the round Cannon Ball shaped tank in the left front fender well area, by the Vapor canistor?

I do not see any indication of one on mine ( except for a plugged Vacuum Line) No mount brackets etc... But there is an empty bracket on the right side front fender well, just about where you would expect to find it ( the Vacuum Tank) on the left side.


Reson i ask is... on start up my engine starts promptly, then starts to run real bad ( 3 - 5 seconds) , missing, barely running, then clears up and idles ok!!!

Almost like it is running real Rich ( accompanyed by the smell).
SES light will come on while driving, indicating a Lean condition, but when idleing the SES light will turn off.

Just dumped a can of SeaFoam into a 3/8 tank of fuel, and will see if that resolves anything.
 
L

LarryK 87

Guest
next day

what a differance, after pouring in the SeaFoam in the Gas ( 5+ gallons of gas left) drive to work ( 5 miles ) sitting all day, went out to start the engine, appeared to back fire, and no start, hit the starter again, immediate fire, and solid idle.
Filled tank with Mobil 93, drive home, sit all night, start up this AM, Immediate fire, and solid idle.

Prognosis: Badly fouled Injectors causeing poor starting. SeaFoam Cleaned them right out.
 

Ken

Gone but not forgotten
Joined
Jan 30, 2001
Messages
8,236
Location
Hermosa Beach, CA
Corvette
1987 Z51 Silver Coupe
Ok, you got me. Just what the heck is "SeaFoam" other than the stuff I see outside my window? :L
 
L

LarryK 87

Guest
seafoam

Sold by Napa, cleans injectors, and top end when poured into fuel tank, Can be used to clean valves, and ports, and combustion chamber if poured into the intake ( they recommend you flood the engine out with it and let it sit 10 - 15 minutes. Also as an additive into the oil ( cleans stuck rings etc).

Worked real good in the fuel, did not try it the otherways.
 

Ken

Gone but not forgotten
Joined
Jan 30, 2001
Messages
8,236
Location
Hermosa Beach, CA
Corvette
1987 Z51 Silver Coupe
Thanks for the explanation Larry, and thanks for the tip. :upthumbs

I am unable to answer your question as to whether all C4s had the reservoir, although I believe they all had it. :confused

_ken :w
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
From 84 -89 For sure you had the "Cannon Ball" the mounts for it were part of the ball ( injection moulded ) it mounted to the engine compartment side of the front inner fender well. ( two holes ) with 1 line going to it.

Vig!
 
L

LarryK 87

Guest
ok... then mine is missing,... so any detremental effects if it is not there?

Have had numerous problems with performance...
1. Surging: Fixed with TB cleaning and IAC replace ( super nasty)
2. Missing: Fixed with tune up
3. Staggering on start up: Fixed with injector Cleaning (seafoam)
4. Trans Hunting while driving: TV cable adjustment
5. SES Code 44: Has not recurred since the Injectors got cleaned

Still has a slight variation in idle ( may still be re-learning) or still has a vacuum leak some where.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom