Welcome to the Corvette Forums at the Corvette Action Center!

1982 Center Console 2 out of 4 lights dont work

Joined
Jul 28, 2003
Messages
1,765
Location
Frankfurt/Germany
Corvette
1982 Collector Edition
Hey Guys,
as you may be able to tell, i am working on the center console there days. The car has to go to inspection in January and i figured i'd get the little stuff out of the way. :eyerole

AC/Ashtray bulb is blown, ah well. Not so easy to get here in the non GM Lands. Not a biggy, i'll get a replacement when i get back to the States. Next up:
2 out of the 4 warning lights fail the light up test at Start/Ignition. Figured, ah right, bulbs. Got a bunch of #194's and got around to taking out the center console. Forgot what a pain it is. Screw removal: 4x Check (2x on the top, 2x on the sides). Remove Knobs and levers from Radio: Check. Remove washers and weirdo screw washer from Radio knobs: Check. Unscrew passenger side carpet board: Check. Remove passenger side screw from under the middle console (only one left down there): Check. Peel out console: Check. Replace Bulbs: Check. Turn key: Same issue. :mad:mad:mad

I exchanged bulbs around to test them. All work fine on the Battery light or the Check Engine Light. The Low Fuel Warning and the Seat Belt warning light: Whatever i did, nothing. Do you guys have any tips what else i can try? I've tried using contact spray on the little twist contacts. Also nothing. They both worked a few weeks ago.

:w
Stefan
 

VETTETECH

Member
Joined
Dec 2, 2015
Messages
24
Location
Chantilly, VA.
Corvette
1987 base
Unlike the early C3's the later model center console panel is like the instrument cluster, in that, it uses a printed circuit to route connections..These are VERY prone to shorting resulting with open circuits..Electrical 101 needed here to remove the unit and test all circuits for continuity..

Joe
 

Antz81

Well-known member
Joined
Dec 21, 2013
Messages
936
Location
Auckland, New Zealand
Corvette
1981 4 speed
i don't believe the fuel light is part of the start up test, only ever seen mine come on when there is low fuel. Might just have to simulate low fuel to check that one.
as for the seat belt light I would test from the buzzer unit (FSM will tell you how) if everything checks out ok I'd replace the buzzer unit
 
Joined
Jul 28, 2003
Messages
1,765
Location
Frankfurt/Germany
Corvette
1982 Collector Edition
i don't believe the fuel light is part of the start up test, only ever seen mine come on when there is low fuel. Might just have to simulate low fuel to check that one.
as for the seat belt light I would test from the buzzer unit (FSM will tell you how) if everything checks out ok I'd replace the buzzer unit
As far as i know the light test should show the Low Fuel light. Mine used to until a few weeks ago. The Seat Belt light: Thats been working only intermittantly, yes, i think the buzzer unit is flaky, though hadnt had a chance to go and test it. Mostly concerned with the Low Fuel light.

low fuel has circuit board with the bulb.Does yours? Low Fuel Warning Module for 1977 1982 Corvette P N 6432350 | eBay
Jim,
yep, has it on the back.

Thanks for the input guys, keep 'em coming.
:w
Stefan
 

Lakeside49

Well-known member
Joined
Nov 29, 2013
Messages
61
Location
USA
Corvette
1982 Red Coupe
You can actually 'unscrew' the low fuel module by removing the glovebox liner and reaching behind the instrument cluster. There is a way to test the module if you do a Google search.


Sent from my iPhone using Tapatalk
 

Peer81

Well-known member
Joined
May 21, 2003
Messages
2,497
Location
Netherlands
Corvette
'81 Black
Low fuel doesn't show at start up, I know for sure :)

Greetings Peter

Verstuurd vanaf mijn GT-I9195 met Tapatalk
 
Joined
Jul 28, 2003
Messages
1,765
Location
Frankfurt/Germany
Corvette
1982 Collector Edition
Sorry Gang.

Been one of those few weeks that nothing came together and my attention was pulled away. Then Holidays, New Years etc etc.. :eyerole

And now, the Vette is really going at it.. I have made the appointment for the mechanic for Feb 22 (earliest i could get) but now the issues started to pile up. And no the Low Fuel light isnt my main issue anymore.. <sighs>

List to do:
- Adjust handbrake (German Inspection demands it sets tight at 3 clicks :eyerole)
- Oil Change
- Oil Filter Change
-> Inspection

Then look at the pile once i get the Inspection/TUeV:
- AMP Meter goes to 18 when driving, 15 when idling. Sure is brighter but...
- Water Temp (Since last night!) going above 200F. (Probably needs a top up: Checking tonight..)
- Error 42 when i stomp the fun pedal, then the CEC goes out again after a minute of limp home mode..
- When the Oil is at Operating Temp, the car wont start, but when jumped starts fine (We've been down this lane before, last year....)
plus the Fuel Warning (Sorry Guys, mine did light up when started)
and lastly: The Courtesy light doesnt work (the one above the gauges) and i cant get a bulb with the zoom lens on it here (Next US Trip!)...

Maybe she over heard me looking at a C7 Z51 here locally in Gun Metal Grey and having a serious thought about it. (Yes, would mean to get rid of the 82 and i dont think i could bear it, so the thought went away again, but maybe this is her revenge?).

I shall come back when we're back from the shop with the findings...



Hib: Yes, of course.. Any page in particular?
Peter: Maybe 81 is different?

I'll let you guys know..

:w
Stefan</sighs>
 

Antz81

Well-known member
Joined
Dec 21, 2013
Messages
936
Location
Auckland, New Zealand
Corvette
1981 4 speed
<sighs>
- Adjust handbrake (German Inspection demands it sets tight at 3 clicks :eyerole)
Wow, that seems excessively tight to me. Here in NZ they want it tight by 10 clicks, but if it's an older car they'll sometimes allow a couple more.

- AMP Meter goes to 18 when driving, 15 when idling. Sure is brighter but...
I assume you mean volt meter, in which case I'd verify it's accurate and then look at the voltage regulator in the alternator.

As for the fuel light probably just ground the sender to see if it lights up, if not you probably need a new module.


Maybe she over heard me looking at a C7 Z51 here locally in Gun Metal Grey and having a serious thought about it. (Yes, would mean to get rid of the 82 and i dont think i could bear it, so the thought went away again, but maybe this is her revenge?).
These cars do seem to get jealous, I went away for 5 weeks, and didn't give mine any attention for about 2 months, and now she's thrown a wheel bearing on me.:L

</sighs>
 
Joined
Jul 28, 2003
Messages
1,765
Location
Frankfurt/Germany
Corvette
1982 Collector Edition
Updated my list, just because (Updates in red).. <sighs>

List to do:
- Adjust handbrake (German Inspection demands it sets tight at 3 clicks :eyerole)
- Oil Change
- Oil Filter Change
- Replace all spark plugs plus 4 & 5 with TSX
-> Inspection

Then look at the pile once i get the Inspection/TUeV:
- VOLT Meter goes to 18 when driving, 15 when idling. Sure is brighter but...
- Water Temp (Since last night!) going above 200F. (Probably needs a top up: Checking tonight..): Topped it off: It was at COLD when it was warm. No change in behaviour though after i drove her topped off <sigh>
- Error 42 when i stomp the fun pedal, then the CEC goes out again after a minute of limp home mode..
- Cylinders 4 & 5 are cold(er) again, time to swap plugs for TSX's (see above)
- When the Oil is at Operating Temp, the car wont start, but when jumped starts fine (We've been down this lane before, last year....)
plus the Fuel Warning (Sorry Guys, mine did light up when started)
and lastly: The Courtesy light doesnt work (the one above the gauges) and i cant get a bulb with the zoom lens on it here (Next US Trip!)...

- And we have a new one (This is the Winner though): Yesterday, after work, started the car, it idled at 1400 in gear, foot on the brake (way above norm). Halfway on my short trip home, she warmed up, she dropped the hi revs and almost went out. I have decided to not drive the car like that and put her away until Saturday and will bring her to the mechanic. Boys is he going to like me.. :eyerole
:w
Stefan</sighs>

<sighs>
Wow, that seems excessively tight to me. Here in NZ they want it tight by 10 clicks, but if it's an older car they'll sometimes allow a couple more.
-> I am biting my tongue to speak ill of my fellow countrymen (but yeah, ba$tard inspectors).

I assume you mean volt meter, in which case I'd verify it's accurate and then look at the voltage regulator in the alternator.
-> Oops, yes, of course Volt meter. And i have good reason to think the regulator is faulty, though this is a new Made in USA alternator from last years trouble. Might be time for another one (Number 6 in this car in the 23 years i have had her)..

As for the fuel light probably just ground the sender to see if it lights up, if not you probably need a new module.
-> Yep, once i get her back driveable, i'll go after that one. Thanks for the tip with the ground.


These cars do seem to get jealous, I went away for 5 weeks, and didn't give mine any attention for about 2 months, and now she's thrown a wheel bearing on me.:L
-> :chuckle Send her the Dropbear Mate!
</sighs>
I shall be back after next week..
 
Joined
Jul 28, 2003
Messages
1,765
Location
Frankfurt/Germany
Corvette
1982 Collector Edition
I shall be back after next week..
kinda sorta next week, so quick update from the trenches...

I talked to my mechanic Monday evening and he was still at it.. Loads of others have come in and are getting ready for spring roll out. But he is working on mine.. So updated list:

List to do:

DONE - Adjust handbrake (German Inspection demands it sets tight at 3 clicks :eyerole)
DONE- Oil Change
DONE- Oil Filter Change
DONE- Replace all spark plugs plus 4 & 5 with TSX
-> Inspection

Then look at the pile once i get the Inspection/TUeV:
- VOLT Meter goes to 18 when driving, 15 when idling. Sure is brighter but...
- Water Temp (Since last night!) going above 200F. (Probably needs a top up: Checking tonight..): Topped it off: It was at COLD when it was warm. No change in behaviour though after i drove her topped off <sigh></sigh>
- Error 42 when i stomp the fun pedal, then the CEC goes out again after a minute of limp home mode..
- Cylinders 4 & 5 are cold(er) again, time to swap plugs for TSX's (see above)
- When the Oil is at Operating Temp, the car wont start, but when jumped starts fine (We've been down this lane before, last year....)
plus the Fuel Warning (Sorry Guys, mine did light up when started)
and lastly: The Courtesy light doesnt work (the one above the gauges) and i cant get a bulb with the zoom lens on it here (Next US Trip!)...

- And we have a new one (This is the Winner though): Yesterday, after work, started the car, it idled at 1400 in gear, foot on the brake (way above norm). Halfway on my short trip home, she warmed up, she dropped the hi revs and almost went out. I have decided to not drive the car like that and put her away until Saturday and will bring her to the mechanic. Boys is he going to like me..

Yeah and what else he found:
DONE - Oil leaking from the speedo cable that goes into the engine/tranny whatever: Replaced seal and cable as it was twisted
in process - Currently he is rebushing the throttle plate/body as he couldnt get them to work properly which explains the Idle issue above.. Once he is done that, he will check the water temp and the rest of the lot.. He is estimating end of next week for my car to get done.. I shall be back to report on the finals..

Old cars are sure fun.. When they work..
:eyerole
 
Last edited:
Joined
Jul 28, 2003
Messages
1,765
Location
Frankfurt/Germany
Corvette
1982 Collector Edition
kinda sorta next week, but i come back with GOOD News.. :happyanim: : Car is back with me, but it was a long slow couple fo weeks (Actually close to 3 Month now :ugh)

Let's update the list once and for all:

DONE - Adjust handbrake (German Inspection demands it sets tight at 3 clicks :eyerole)
DONE- Oil Change
DONE- Oil Filter Change
DONE- Replace all spark plugs
DONE- Inspection Until May 2018

Pile:
DONE- VOLT Meter goes to 18 when driving, 15 when idling. Sure is brighter but... - The regulator in the Alternator was faulty. Rebuild/Replaced circuit board
DONE- Water Temp (Since last night!) going above 200F. (Probably needs a top up: Checking tonight..): Topped it off: It was at COLD when it was warm. No change in behaviour though after i drove her topped off - We had a faulty seal at the cap, replaced<sigh></sigh>
DONE- Error 42 when i stomp the fun pedal, then the CEC goes out again after a minute of limp home mode.. - Never showed up again
DONE- Cylinders 4 & 5 are cold(er) again, time to swap plugs for TSX's (see above) - Replaced the spark plugs, distributor cap and cables to spark plugs
DONE- When the Oil is at Operating Temp, the car wont start, but when jumped starts fine (We've been down this lane before, last year....) - Homemade problem: My extra Anti Theft Alarm went crazy and killed the ignition after warm. Circumvented feature now, as it's really useless to have here (Plus Car goes from home Garage to Work Garage).

Ignored:
the Fuel Warning (Sorry Guys, mine did light up when started)

The Courtesy light doesnt work (the one above the gauges) and i cant get a bulb with the zoom lens on it here (Next US Trip!)...

DONE- And we have a new one (This is the Winner though): Yesterday, after work, started the car, it idled at 1400 in gear, foot on the brake (way above norm). Halfway on my short trip home, she warmed up, she dropped the hi revs and almost went out. I have decided to not drive the car like that and put her away until Saturday and will bring her to the mechanic. Boys is he going to like me.. - Rebuild the throttle bushings as none available to purchase here or back in the USofA, which took forever

Extras:
DONE - Oil leaking from the speedo cable that goes into the engine/tranny whatever: Replaced seal and straightened cable as it was twisted
But, he was very kind on the bill and i have my car back. Dirty but purring like a kitten.. :happyanim::happyanim::happyanim:

:w Stefan

PS: i'll go after the Low Fuel and bulb above once i had the chance to drive her around again
PPS: Sorry about the colors, i am a bit exuberant, can you tell..
 

Antz81

Well-known member
Joined
Dec 21, 2013
Messages
936
Location
Auckland, New Zealand
Corvette
1981 4 speed
That's great news :thumb

Just a small note on the fuel sender. Since yours has been lighting up with the lights test it would seem it has a different module to the 81. (I went over the circuit on mine and there's nothing there for a lamp test)
 
Joined
Jul 28, 2003
Messages
1,765
Location
Frankfurt/Germany
Corvette
1982 Collector Edition
That's great news :thumb

Just a small note on the fuel sender. Since yours has been lighting up with the lights test it would seem it has a different module to the 81. (I went over the circuit on mine and there's nothing there for a lamp test)

So, just to give everyone a final:
I was in the USA late June for a weekend trip (First wedding of a nephew, wife insisted we go, bit of a drag but..), so i had ordered an extra low fuel warning module (from Wilcox' Ebay store) for all of 20$ and a few Console light bulbs. Just got done replacing both and the winner is: You Guys.. Looks like my brain isn't remembering right, and you guys have been right all along. The new one isn't lighting up on lamp check, so, must be me getting old (Or as my daughter says: You are old !). Haven't watched the new board coming on for low fuel as the tank is full, but if it doesn't, I'll chase that gremlin. I shall now go into my corner and sulk for not believing you. :D

:w
-Stefan
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom