Welcome to the Corvette Forums at the Corvette Action Center!

Question: 1985 running rough at idle after warming up

AirJohn

Member
Joined
Jul 7, 2008
Messages
10
Location
Auburn Calif
Corvette
1985 Red & 1985 Black
Having issues with one of our 1985 Corvettes, it started running rough after it warmed up, running around 198 degrees or so, not getting too hot. 200,000 miles on this one. Sometimes it acted rough at highway speeds. Passed Calif SMOG test here 4 months ago. Engine ran great until it reached operating speed. First showed an error code of 54 that is the fuel pump circuit fault or mixture control solenoid fault (not used on this engine), or ECM failure, so the book said. Pressure gauge showed fuel rails around 32 so I replaced the pump and tank filter, showing 40 now. Replaced the main fuel line filter also. Replaced the fuel pump relay and harness connector, replaced the oil pressure switch at back of the intake manifold/block (Napa OP6624 and OP6638). Replaced the spark plugs with AC Delco CR43TS, still ran like crap when warmed up, most of the time.

Then I started getting code 44 (lean mixture), then 45 (rich mixture). Replaced the Idle Air Control (Master Pro 2-IAC1 21738), got the same codes. Replace the Oxygen sensor, the one I removed looked good and was a little sooty black (BOSCH 12014). Cleared the codes again, ran OK for a few short runs, then codes 44 and 54 are back again. I ran a fresh new wire from power back to the fuel pump directly, that did not help. (Unswitched power is always hot to the oil pressure switch, then goes to the fuse panel, then to the fuel pump, the fuel pump relay is only used when starting the engine, then becomes dormant and the oil pressure switch keeps the fuel pump operating). I removed the vacuum line from the EGR valve and blocked it off, thinking it was sticking open and not closing at idle speed, same results. I can not see the operation of the EGR valve, I am not wanting to remove the plenum to get at that valve if I do not need to do that. What am I missing here?;shrug:duh
 

John Robinson

Gone but not forgotten
Joined
May 3, 2005
Messages
1,555
Location
Muncie, Indiana
Corvette
1993 Polo Green Coupe
With the age and mileage of the car you need to look at the grounds on the frame and bell housing and in the wiring harness. Remember the codes only tell you something is not right in the signal from a circuit. That means if a wire is broken or a bad ground is there the ecm gets a false reading. Next different sensors come into play if the car is up to temp and in open or closed loop. So if the problem starts when the operating temp get to the point were it goes from open to closed loop then you need to look at the sensors that are involved at that time. The wires used for the sensors are very small and brittle and easily broken with handling. Again bad signals to the ecm and it will try to compensate to keep the engine running. As for the grounds in the wiring harness the grounds from the TPS, Water TEmp Sensor, MAF, IAC and probable a couple others come together in a common ground bundle in the wiring harness.
 

John Robinson

Gone but not forgotten
Joined
May 3, 2005
Messages
1,555
Location
Muncie, Indiana
Corvette
1993 Polo Green Coupe
The following is from a 93 manual but it should help you to get an understanding of what all is going on with your car.

DRIVEABILITY AND EMISSIONS S.7L (VIN P) 6E3-A-19

TYPICAL TeCH 1 DATA DEFINITIONS

ECM DATA DESCRIPTION

A list of explanations for each data message

displayed on the Tech 1 scan tool begins below.

This information will assist in tracking down

emission or drivability problems, since the displays

can be viewed while the vehicle is being driven. See

the "On-Board Diagnostic (OBO) System Check" for

additional information.

With the Tech
1connected, the ASR system may

be disabled and the "Service ASR" light may turn

"ON."

ENGINE SPEED - Range 0-9999 RPM -
Engine speed is

computed by the ECM from the distributor reference

input (low resolution circuit). It should remain close to

desired idle under various engine loads with engine

idling.

r:

DESIRED IDLE - Range 0-3187 RPM -
The idle speed

that is commanded by the ECM. The ECM will

compensate for various engine loads to keep the engine

at the desired speed.

ENG COOL TEMP - Range -40°C to 151°C, -40°F to 304°F

- The Engine Coolant Temperature (ECT) sensor is

mounted in the coolant pump and sends engine

temperature information to the ECM. The ECM

supplies 5 volts to the ECT sensor circuit. The sensor

is a thermistor which changes internal resistance as

temperature changes. When the sensor is cold

(internal resistance high), the ECM monitors a high

signal voltage which interprets it as a cold engine. As

the sensor warms (internal resistance decreases), the

voltage signal will decrease and the ECM will

interpret the lower voltage as a warm engine.

INTAKE AIR TEMP - Range -40°C to 196°C. -40°F to

38soF -
The ECM converts the resistance of the intake

air temperature sensor to degrees. Intake Air

Temperature (IAT) is used by the ECM to adjust fuel

delivery and spark timing according to incoming air

density.

MAP - Range 11-105 kPa/0.00-5.10 Volts -
The

Manifold Absolute Pressure (MAP) sensor measures

the change in the intake manifold pressure which

results from engine load and speed changes. As intake

manifold pressure increases, the air density in the

intake manifold also increases and additional fuel is

required.

BARO - Range 11-105 kPa/0.00-S.10 Volts -
The BARO

reading displayed is measured from the MAP sensor at

key "ON," engine "OFF" and WOT conditions. The

BARO reading displayed represents barometric

pressure and is used to compensate for altitude

differences.

THROT POSITION - Range 0-S.10 Volts -
Used by the

ECM to determine the amount of throttle demanded by

the driver. Should read .36-.96 volt at idle to above 4

volts at wide open throttle.

THROTTLE ANGLE - Range 0 - 100% -
Computed by the

ECM from TP sensor voltage (Throttle Position) and

should read 0% at idle and 100% at wide open throttle.

Refer to DTC 21 ifTP sensor angle is not 0% at idle.

OXYGEN SENSORS- Range 0-996 mV -
Represents the

exhaust oxygen sensor output voltage. Should

fluctuate constantly within a range between 10 mV

(lean exhaust) and 1000 mV (rich exhaust) when

operating in "Closed Loop."

lOOP STATUS - Tech 1 ~isplays Open or Closed -

"Closed Loop" displayed indicates that the ECM is

controlling fuel delivery according to oxygen sensor

voltage. In "Open Loop," the ECM ignores the oxygen

sensor voltage and bases the amount of fuel to be

sensor inputs only.
delivered on TP sensor, engine coolant, and MAP

sensor inputs only.

SHORT TERM FUEL TRIM - Range 0-2SS -
Short term

fuel trim represents a short-term correction to fuel

delivery by the ECM in response to the amount of time

the oxygen sensor voltage spends above or below the

450 mV threshold. If the oxygen sensor voltage has

mainly remained below 450 mV, indicating a lean

air/fuel mixture, short term fuel trim will increase to

tell the ECM to add fuel.
If the oxygen sensor voltage

stays mainly above the threshold, the ECM will reduce

fuel delivery to compensate for the indicated rich

condition.

LONG TERM FUEL TRIM - Range 0-2SS -
Long term fuel

trim is derived from the short term fuel trim value and

is used for long-term correction of fuel delivery. A

value of 128 counts indicates that fuel delivery

requires no compensation to maintain a 14.7:1 air/fuel

ratio. A value below 128 counts means that the fuel

system is too rich and fuel delivery is being reduced

(decreased injector pulse width). A value above 128

counts indicates that a lean condition exists and the

ECM is compensating by adding fuel (increased

injector pulse width).


NOTE WHAT THIS TELLS YOU ABOUT HOW THE TPS WILL CAUSE UNSTABEL IDLE
By monitoring the output voltage from the TP sensor, the ECM can determine fuel delivery based on throttle valve angle (driver demand). A broken or loose TP sensor can cause intermittent burst of fuel from the injectors and cause an unstable idle, because the ECM detects the throttle is moving.


 

Schrade

Well-known member
Joined
May 2, 2009
Messages
1,315
Location
Not in CF; BANNED!!!
Corvette
'90 LT 5
Good job testing fuel pressure.

Did you check pressure bleed-down time? Leaking injectors might make a pressure test show 32, and the pump works perfectly.

Do you have a multimeter?

And what 'book' do you have? Chilton's? Or Haynes? Or Clymer? The fact that 54 code means 2 different things (from 2 lists, of course), tells me with about 100% probability, that you have one of those books. TOSS IT.

Post back your bleed down time.

As John R said, device 'X' circuit, means device 'X' CIRCUIT' If the ground is cut, or if the power supply is cut, we can replace device 'X' until gas goes to $1.29 / gallon, and device 'X' ain't gonna' work.

And don't get me wrong - I have an index fund for auto parts retailers, and it's doing well. If you want to keep on replacing good parts, more power to ya'! :thumb
 

AirJohn

Member
Joined
Jul 7, 2008
Messages
10
Location
Auburn Calif
Corvette
1985 Red & 1985 Black
Good job testing fuel pressure.

Did you check pressure bleed-down time? Leaking injectors might make a pressure test show 32, and the pump works perfectly.

Do you have a multimeter?

And what 'book' do you have? Chilton's? Or Haynes? Or Clymer? The fact that 54 code means 2 different things (from 2 lists, of course), tells me with about 100% probability, that you have one of those books. TOSS IT.

Post back your bleed down time.

As John R said, device 'X' circuit, means device 'X' CIRCUIT' If the ground is cut, or if the power supply is cut, we can replace device 'X' until gas goes to $1.29 / gallon, and device 'X' ain't gonna' work.

And don't get me wrong - I have an index fund for auto parts retailers, and it's doing well. If you want to keep on replacing good parts, more power to ya'! :thumb

I have the GM 1985 Corvette Factory Service Manual, I got the code meanings from the FSM, the book that came with my code reader jumper device, and from these forums where you all post information that I would think would be correct, and that I trust to be mostly accurate. I work on Turbine and Piston aircraft and helicopters, applied some of that logic to this troubleshooting situation here. The fuel injectors are not leaking down. I admit I am not pleased with "shot gunning" components to fix an issue but when I see these parts are 25 years old already, it is an "investment" in keeping this Corvette relilable, even if it does not totally solve the problem I will know next time I have an issue where not to look. The grounds, I am working on replacing most of them this week. Today we will be using a scan tool to read the RS232 data to see if anything shows up there, will keep you informed of the results.
 

John Robinson

Gone but not forgotten
Joined
May 3, 2005
Messages
1,555
Location
Muncie, Indiana
Corvette
1993 Polo Green Coupe
It sounds to me like you have the skills to run this problem to ground. You are right there are different codes depending on the model year. My information was only intended to give you another avenue to look at. I should have mentioned that with similar symptoms on my car I spent the better part of 6 months running in circles until I found a bad wire on the TPS. I found that when I cleaned the grounds the car ran some better. One thing I did that made a big difference was to pull the connectors on the ecm and use a little dielectric grease in each pin hole. and on all the connectors. After I did that it seemed to transform the way the car ran. But I still had some idling problems and a flat spot under WOT until I replaced the injectors with Bosch three injectors from Fuel Injector Connections. Personally I hate to come right out and say I think this is the problem. That is because I have found that with the way these cars are controlled by the ECM and all the sensors they can display the same symptoms and be caused by totally different things. I also go by the saying Tell me, and I will forget - Show me, I may remember - But involve me, and I'll understand.
 

WhalePirot

Well-known member
Joined
May 9, 2002
Messages
2,942
Location
SoCA
Corvette
1984 White Z-51/ZF6-40/Shinoda body
All good feedback, but don't forget the basics. I recommend checking the vacuum, too, perhaps a leak is covered up by open loop op. Low vacuum will tell the ECM to add fuel, it thinking that the engine is under load.

BTW, an O2 sensor can be cleaned with a torch; check the web. I've done it successfully; carbon fouling is a good candidate, while underscoring the rich condition. Left unrepaired, look for a ruined CAT, in time. :w
 
T

timvette

Guest
Having issues with one of our 1985 Corvettes, it started running rough after it warmed up, running around 198 degrees or so, not getting too hot. 200,000 miles on this one. Sometimes it acted rough at highway speeds. Passed Calif SMOG test here 4 months ago. Engine ran great until it reached operating speed. First showed an error code of 54 that is the fuel pump circuit fault or mixture control solenoid fault (not used on this engine), or ECM failure, so the book said. Pressure gauge showed fuel rails around 32 so I replaced the pump and tank filter, showing 40 now. Replaced the main fuel line filter also. Replaced the fuel pump relay and harness connector, replaced the oil pressure switch at back of the intake manifold/block (Napa OP6624 and OP6638). Replaced the spark plugs with AC Delco CR43TS, still ran like crap when warmed up, most of the time.

Then I started getting code 44 (lean mixture), then 45 (rich mixture). Replaced the Idle Air Control (Master Pro 2-IAC1 21738), got the same codes. Replace the Oxygen sensor, the one I removed looked good and was a little sooty black (BOSCH 12014). Cleared the codes again, ran OK for a few short runs, then codes 44 and 54 are back again. I ran a fresh new wire from power back to the fuel pump directly, that did not help. (Unswitched power is always hot to the oil pressure switch, then goes to the fuse panel, then to the fuel pump, the fuel pump relay is only used when starting the engine, then becomes dormant and the oil pressure switch keeps the fuel pump operating). I removed the vacuum line from the EGR valve and blocked it off, thinking it was sticking open and not closing at idle speed, same results. I can not see the operation of the EGR valve, I am not wanting to remove the plenum to get at that valve if I do not need to do that. What am I missing here?;shrug:duh
hi, i had probs with an 85, part was a cold start valve..so called 9th injector, ppl forget about them, check that out, process of elimination
 

AirJohn

Member
Joined
Jul 7, 2008
Messages
10
Location
Auburn Calif
Corvette
1985 Red & 1985 Black
Will be using a scan tool, engine going into limp mode?

Will be using a Snap On Solus Pro scanner this week, still getting the error 54 about the fuel pump but we know it is operating with full voltage as I have temporarily installed a secondary power line to the new fuel pump. Pin 82 on the ECM is motoring the pump voltage, if there is a problem with a bad connection as John R mentioned I can see logically why a code 54 is shown. It was also mentioned that the code 54 condition could be putting the engine into "limp home condition", what ever that is. I have not been able to find out very much about that mode here, and there is no error code for it. I have checked for vacuum leaks, there are none. Thanks for the tip about cleaning the Oxygen sensor, I will look into that. Hoping the Solus will point us in the right direction this week, one of the new guys at work has one from a previous job, next step will likely be to pull the ECM although I am not looking forward to digging into the dash there.
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
ECU pull easy peasy start with POWER OFF

On the passenger side under the dash, there are 5 1/4 inch screws on the bottom side of the dash, remove them pull the plastic cover down, disconnect the courtesy light mounted on the panel, stow panel. Next you will need a 10mm tall socket look straight up you will see the ECM it is aluminum with 2 wire harness attached. There is a metal clip holding it attached pull it back and un hook the harness then the ECM will slide right out.
 

AirJohn

Member
Joined
Jul 7, 2008
Messages
10
Location
Auburn Calif
Corvette
1985 Red & 1985 Black
No room to access the computer inside the garage

On the passenger side under the dash, there are 5 1/4 inch screws on the bottom side of the dash, remove them pull the plastic cover down, disconnect the courtesy light mounted on the panel, stow panel. Next you will need a 10mm tall socket look straight up you will see the ECM it is aluminum with 2 wire harness attached. There is a metal clip holding it attached pull it back and un hook the harness then the ECM will slide right out.

I have pulled both computers in our "his and hers" 1985 Corvettes, replaced both heater cores also. I am dreading having to pull the computer in "hers" because it is freezing cold here at night and there is not enough room inside the garage to fully open both doors on her Corvette to get to the computer.
 
Last edited:

AirJohn

Member
Joined
Jul 7, 2008
Messages
10
Location
Auburn Calif
Corvette
1985 Red & 1985 Black
I found the problem, bad connections at and inside ECM and more

Removed the ECM and found a connector pin was partially dislodged, pin D-1, one of the 12 volt connections. Next I opened the ECM and re-soldered some of the points on the circuit board where the connector pins attached there. Then I soldered pigtails onto all of the Ground wires going to the connectors, pins A12, D1, D3, and ran a heavy wire to a good Ground on the engine block. Used a very small wire brush to clean oxidation off of all the pins on the connector of the ECM. Engine has been running fine now for a week or so. It was weird to be getting one error code saying rich exhaust and at the same time getting the code for lean exhaust, and a code saying there was low voltage to the fuel pump.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Advertise with the Corvette Action Center!

Double Your Chances!

Our Partners

Top Bottom