Welcome to the Corvette Forums at the Corvette Action Center!

'93 Courtesy Light Relay Location and Access

echo4golf

Well-known member
Joined
Oct 9, 2017
Messages
55
Location
BaltoWash MD
Corvette
1993 40th Anniversary Coupe
Hi Folks,

Having an issue with the courtesy lights in my '93. The issue started with the lights flashing on and off randomly while driving and progressed the lights staying on all the time--even after the DAB should have shut them down. I tried adjusting the switches and wound up replacing one of them to no avail. I pulled the codes and got a 25 (Courtesy lamp relay coil open or shorted to ground.)

The ground seems to be OK. But when I trigger the relay, there is an audible buzzing. The lights go on and off this way.

Right now my plan is to replace it. Here's the catch: I can't get to it. In the FSM, it looks like it's behind the passenger's side knee bolster. The diagrams shows two sets of relays, one with three and one with two. I pulled the bolster and found the one, but the other seems to be hidden out of reach. I can hear it buzzing away back there too, but can't seem to locate it.

Does anyone know, can I pull the glove box to get to it?

Or am I stuck trying to work upside down and backward in the passenger's seat. I'd rather not pull the seat, although I guess that's an option. (Of course, if I pull the seat, I can strip the cover and repair the inflateable parts.... But then I'd have to do the driver's side. And while I'm at it... NO! Daggone sequences will get you every time.)

Thanks,
Jerry
 

echo4golf

Well-known member
Joined
Oct 9, 2017
Messages
55
Location
BaltoWash MD
Corvette
1993 40th Anniversary Coupe
And the answer is yes... The relay sets were not mounted as shown in the Service Manual.. Rather, they were tucked up behind the knee bolster. The one that I needed was actually inaccessable and up on top of the heater vent. It turns out that the only way I could get to it was to pull the glove box. Once I did that I could get a couple of fingers down on it and push it through to where I could work on it.

I replaced the relay, and the lights are working and the delayed accessory bus now seems to work correctly and everything shuts off.

The relay, though, is still buzzing when in use not quite as bad as the old one but enough that it's noticeable and I'd like to figure out what's wrong with it. Do I need to look at the ground?

Thanks,
Jerry

Sent from my SM-T310 using Tapatalk
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom