Welcome to the Corvette Forums at the Corvette Action Center!

A/C quit working

M

mike78

Guest
My '78 air conditioning quit working. I have not had this car very long. When I first got it the heat and A/C both worked. Now I it won't blow any air, hot or cold. I am not mechanically inclined, but I prefer to do the work myself, if it possible. What's the problem? Is this something I can fix myself or do I have to take it to the shop?
 

LVMYVT76

Well-known member
Joined
Apr 21, 2006
Messages
664
Location
springfield, mo
Corvette
1976 medium blue
More information, fan running, a/c belt on?? compressor turning and clutch engaging?? freon lines hot or cold?? had to say without more info. engine running rougher from vaccum leaks of a/c heater system??
 
M

mike78

Guest
More information, fan running, a/c belt on?? compressor turning and clutch engaging?? freon lines hot or cold?? had to say without more info. engine running rougher from vaccum leaks of a/c heater system??

I know the fan is running, the a/c belt is on and the engine is not running rougher. I have not checked to see if the compressor is turning or the clutch is engaging and I have not checked to see if the freon lines are hot or cold. I can tell you that I have not noticed the compressor kicking on and off so maybe that's it. I will check out the lines and the compressor. Thanks for replying so quick.
 

LVMYVT76

Well-known member
Joined
Apr 21, 2006
Messages
664
Location
springfield, mo
Corvette
1976 medium blue
you may be low on charge, the compressor will kick in and out alot for a while if this is the problem.. You can jump the low pressure switch to see if the compressor will run. I don't know if you have a sight glass on your high side line, but if you do you should see small bubbles in it if it is low on charge. 12 volts should be at the green wire on the compressor if it is getting voltage. If not start tracing backwards on the green wire to see where the problem is. What about a fuse in the fuse panel?? or is there an inline fuse somewhere???
 

bill81vette

Moderator
Joined
Jan 17, 2004
Messages
4,272
Location
Troy,NY
Corvette
1981 dark blue metallic
Now I it won't blow any air, hot or cold.


based on that statement alone,I would check to see if the fuse is bad which would be why your blower isnt working!!
good luck
 
S

Superman

Guest
Yeah, check the fuse. My A/C never worked, but I never bothered with it because I always drive with the tops off. But last week I blew the fuse for the radio, so I checked all my fuses while I was at it. Turns out the fuse for the A/C was blown. Replaced the fuse and now works fine.

If it is the fuse, make sure you replace it with the same amount of amps. Should be a list of correct amps listed next to each fuse on the fuse box.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom