Welcome to the Corvette Forums at the Corvette Action Center!

Help! Electrical gremlins with climate control, aerial & dash

Jklumpp

Member
Joined
Nov 21, 2018
Messages
5
Location
New South Wales
Corvette
1991 Yellow Coupe
A strange thing happened when I drove my corvette today.....
As a background, I have a parasitic power drain problem that I have not got to the bottom of. If my car is not driven for a few days, the battery will go completely dead (only a new battery), so I generally keep it on a charger.
I've just got back from a weeks holiday, so the car has been sitting for some time with the battery on charge.
When I drove it today, all was OK - until Parked it and noticed the first issue - the electric aerial did not go down.... I turned the ignition on & off a few times, but still no good.
Then when I left to drive home I noticed 'SYS' appear on the dash, where the range/fuel economy is usually displayed... it eventually changed to the range, but would intermittently flash 'SYS' as I drove
Then the third thing I noticed was that I had no climate control! The orange background light was on, but there was nothing on the display, and no lights on the AUTO or OFF buttons, and I could not raise any codes by pressing the fan up/down buttons....

When i got home I disconnected the battery for 5 minutes, and then reconnected hoping it just needed a reset, but no joy.... all problems still there.
I also checked the fuses, and they all appear OK.

Any suggestions?
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom