Welcome to the Corvette Forums at the Corvette Action Center!

Help! injectors not working, bad computer ?

hotrod2

Well-known member
Joined
Jul 11, 2014
Messages
50
Location
illinois
Corvette
1985 c4
hi everyone i have a 1985 c4 ,and the injectors dont work ,it will start with fuel down the throttle body ,and my left headlight has sounds coming from the motor ,and passenger door light stays on will the car still start like this if the computer is bad?,bad alarm chip? ive never had computer problems before so this is all new to me,thanks for any help,or advice
 

mr.beachcomber

Active member
Joined
Nov 27, 2007
Messages
42
Location
Virginia Beach, VA
Corvette
1989 Black Z51 Coupe
hi everyone i have a 1985 c4 ,and the injectors dont work ,it will start with fuel down the throttle body ,and my left headlight has sounds coming from the motor ,and passenger door light stays on will the car still start like this if the computer is bad?,bad alarm chip? ive never had computer problems before so this is all new to me,thanks for any help,or advice
First off, if you Vette will only start when you pour fuel down the throttle body, it sounds like you may have a faulty cold start injector or the fuel rail isn't being pressurized during the start up procedure. You need a fuel pressure gauge to measure fuel pressure at the fuel rail Schrader valve. When you turn the ignition key to run, the fuel pump should run for a few seconds bringing the fuel rail to ~40-43 Lb before cranking. You can test the cold start injector for resistance (~12-14 Ohms) as well as check for a firing voltage at the harness. If the injector is firing, you can hear a faint ticking sound using a mechanic's stethoscope.

As for you head light motor, if the motor is running or making sounds without the headlight switch being activated, you possibly have a short in the motor. The passenger door light could be a sensor problem or a timer relay neither of which is related to the ECM (computer).

I would recommend that you purchase an 1985 Corvette service manual off Ebay if one isn't available on this forum. (Advertise for a WTB to see if someone has one that they'll sell.) It's hard to trouble shoot these early C4's without the service manual. Good Luck! :beer
 

WhalePirot

Well-known member
Joined
May 9, 2002
Messages
2,942
Location
SoCA
Corvette
1984 White Z-51/ZF6-40/Shinoda body
The principles are the same as a non-ECM car, but the implementation requires some additional, different tools. A good fuel pressure in addition to the FACTORY FSM (not Haynes, etc.) are two. You'll also want a good DVOM with some electrical troubleshooting skills.

I'd expect that just a bad cold start injector would not prevent the car starting, IF the FP rises as described. That 'extra' injector was akin to a choke, adding fuel when for cold running, and was eliminated in later years. I'd expect it to fire and probably start, but not run well until warm.
 

mr.beachcomber

Active member
Joined
Nov 27, 2007
Messages
42
Location
Virginia Beach, VA
Corvette
1989 Black Z51 Coupe
...I'd expect that just a bad cold start injector would not prevent the car starting, IF the FP rises as described. That 'extra' injector was akin to a choke, adding fuel when for cold running, and was eliminated in later years. I'd expect it to fire and probably start, but not run well until warm.
My shop experience with pre-89 Vettes indicates otherwise. The cold start injector is necessary to provide the extra fuel needed for a cold start. (The '89 and later Vettes had the ECM lengthen the injector pulse for cold starts so the cold start injector could be eliminated.) If the cold start injector isn't supplying the extra fuel, you may get intermittent firing, but the engine won't run. One thing to avoid is feathering the throttle while the engine is cranking with sporadic firing. This sends the ECM into the "flooded engine" mode and the injector pulses are shortened causing a lean, no-fire condition.

One extra thing to check is the type of injector you have installed on the engine. 1985 Vettes used a Bosch 24 LB injector while '86-'91 Vettes used nominal 21-22 LB injectors from various sources. If you have the wrong injector(s) installed, you'll get great gas mileage during cruise conditions, but the Vette will be hard to start even with a good cold start injector. There are several sites that provide injector info, but you can post your finding in this thread if you like. I'm sure someone, if not me, will be able to tell you what you have installed.

Hope you resolve your problem soon so you can enjoy your Vette! :w
 

hotrod2

Well-known member
Joined
Jul 11, 2014
Messages
50
Location
illinois
Corvette
1985 c4
thanks for replys, i now see no fuel pressure,or power to the fuel pump ,any one know where the fuel,window,and,mirror relays are, i think the fuel relay is by the fuel pump but my haynes manuel doesnt say where the others are thanks again i will keep everyone posted after i get the new computer
 

mr.beachcomber

Active member
Joined
Nov 27, 2007
Messages
42
Location
Virginia Beach, VA
Corvette
1989 Black Z51 Coupe
thanks for replys, i now see no fuel pressure,or power to the fuel pump ,any one know where the fuel,window,and,mirror relays are, i think the fuel relay is by the fuel pump but my haynes manuel doesnt say where the others are thanks again i will keep everyone posted after i get the new computer
The fuel pump relay is inside the engine bay next to the vacuum brake booster as shown in the attached diagram. (This is from my 1989 service manual, but it's the same for your 1985.)
Engine Component Locations.JPG

The windows and mirrors don't have relays per se, but their fuses are located in the fuse block located in the dash end panel on the passenger side.
Fuse Block Details.JPG

The Haynes manual is okay for general maintenance, but is useless for real troubleshooting. You need a factory service manual! :thumb
 

hotrod2

Well-known member
Joined
Jul 11, 2014
Messages
50
Location
illinois
Corvette
1985 c4
The fuel pump relay is inside the engine bay next to the vacuum brake booster as shown in the attached diagram. (This is from my 1989 service manual, but it's the same for your 1985.) View attachment 19340 The windows and mirrors don't have relays per se, but their fuses are located in the fuse block located in the dash end panel on the passenger side. View attachment 19341 The Haynes manual is okay for general maintenance, but is useless for real troubleshooting. You need a factory service manual! :thumb
thanks i did see that and someone replaced the fuel pump relay, but still no power ,i see 2 small relays near the pump as well maybe one is the hatch ,it does work the window motors work with power to them directly but not through the switches,and the door locks work i switched the door and window relays, the locks work with either relay ,so they are both good no power to the mirrors though also i read about the cold start fuse so i need to check it now i hat electrical problems
 

Schrade

Well-known member
Joined
May 2, 2009
Messages
1,315
Location
Not in CF; BANNED!!!
Corvette
'90 LT 5
Get RID of the Haynes manual - it's ABSOLUTELY worthless.

Now if Haynes had a round, hollow binding, it would have a place in the 'library', where the seat has a big hole in the middle; you know... read a page, tear, wipe, flush, repeat if necessary.

('krinkle it up good, between 'tear', and 'wipe', if you're tender in the hindquarters kissmyass.png ). And of course, hindquarters are like opinions - all have one, and all wipe 'em different, so substitute for 'wipe' (front to rear, rear to front, blot, sideways, swirlie, spin, etc., ...)

eBay surely has '85 Factory Shop Manual. The cost will be saved FIRST repair that you do. Guaranteed.
 

hotrod2

Well-known member
Joined
Jul 11, 2014
Messages
50
Location
illinois
Corvette
1985 c4
First off, if you Vette will only start when you pour fuel down the throttle body, it sounds like you may have a faulty cold start injector or the fuel rail isn't being pressurized during the start up procedure. You need a fuel pressure gauge to measure fuel pressure at the fuel rail Schrader valve. When you turn the ignition key to run, the fuel pump should run for a few seconds bringing the fuel rail to ~40-43 Lb before cranking. You can test the cold start injector for resistance (~12-14 Ohms) as well as check for a firing voltage at the harness. If the injector is firing, you can hear a faint ticking sound using a mechanic's stethoscope. As for you head light motor, if the motor is running or making sounds without the headlight switch being activated, you possibly have a short in the motor. The passenger door light could be a sensor problem or a timer relay neither of which is related to the ECM (computer). I would recommend that you purchase an 1985 Corvette service manual off Ebay if one isn't available on this forum. (Advertise for a WTB to see if someone has one that they'll sell.) It's hard to trouble shoot these early C4's without the service manual. Good Luck! :beer
thanks for the help i read about the cold start fuse,and had not checked it yet well,new computer and cold start fuse and it started!!! i need new plugs, some were flooded from the prev owner and now i can get the codes with the new computer! lol, getting there slowly but surely THANKS MR BEACHCOMBER AND EVERYONE ELSE!!! NEXT-----dimmm dash lights!!! thinking it might be a bad alternator not putting out enough power?.......
 

hcbph

Well-known member
Joined
Aug 30, 2013
Messages
260
Location
Minneapolis, Mn.
Corvette
86 Red Convertible
Dash

--dimmm dash lights!!! thinking it might be a bad alternator not putting out enough power?.......
That could just as easily be some of the dash lights are out - been there, done that. If yours is like mine (which I believe it is), pull the bezel off the dash and there are 4 metal plugs on the front. Each one covers one of the bulbs that illuminate the dash from the back. You can pop then off and see if the lights are working or not. When I got mine, multiples were out and replacing them helped a lot in viewing the dash.
 

hotrod2

Well-known member
Joined
Jul 11, 2014
Messages
50
Location
illinois
Corvette
1985 c4
That could just as easily be some of the dash lights are out - been there, done that. If yours is like mine (which I believe it is), pull the bezel off the dash and there are 4 metal plugs on the front. Each one covers one of the bulbs that illuminate the dash from the back. You can pop then off and see if the lights are working or not. When I got mine, multiples were out and replacing them helped a lot in viewing the dash.
hey thanks for the reply, the lights come on when you turn on the ignition on , but go dim after that so it cant be a bulb also if you shine a light on the dash they light up / glow,like nightglow toys ,i guess it the illumination material? i don't know what would take the power away ,it seems like a bad relay working then bypassing / 'working verry little' but the instrament cluster uses a standard fuse
 

hcbph

Well-known member
Joined
Aug 30, 2013
Messages
260
Location
Minneapolis, Mn.
Corvette
86 Red Convertible
Photocell

hey thanks for the reply, the lights come on when you turn on the ignition on , but go dim after that so it cant be a bulb also if you shine a light on the dash they light up / glow,like nightglow toys ,i guess it the illumination material? i don't know what would take the power away ,it seems like a bad relay working then bypassing / 'working verry little' but the instrament cluster uses a standard fuse
There's a photocell in the corner of the cluster. try putting your thumb over it and see if it changes the illumination. Check out this website to see if there's anything there to help out: BATEE.COM - 1984 - 1996 C4 Corvette Electronics Repair Services, Parts and DIY
 

hotrod2

Well-known member
Joined
Jul 11, 2014
Messages
50
Location
illinois
Corvette
1985 c4
There's a photocell in the corner of the cluster. try putting your thumb over it and see if it changes the illumination. Check out this website to see if there's anything there to help out: BATEE.COM - 1984 - 1996 C4 Corvette Electronics Repair Services, Parts and DIY
thanks i seen it on youtube ,i found out it was a red wire burnt in half at the starter! ,fixed and dash works good and charges at 14volts now :) ,now its running but only 20lpsi of fuel pressure at the rail valve ,i have the newer fuel tank and new pump need the sending unit ,and it seems a pain in the aszzz to put the tank in from the book anyway again thanks to everyone for advice ,this is a long term project
 

hotrod2

Well-known member
Joined
Jul 11, 2014
Messages
50
Location
illinois
Corvette
1985 c4
got a new computer injectors work fine sorry i forgot to update this, fixed red wire to starter, dash is on and bright and bat charges now
just going through the whole damn car now,
--fixed fuel pump relay and pig tail
--fixed coolant fan relay and pigtail
--fixed mass air pigtail
--fixed fog lights and ground


--next is window switch no power issue
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom