Welcome to the Corvette Forums at the Corvette Action Center!

Instrument Cluster

gaC5

Well-known member
Joined
Sep 14, 2001
Messages
102
Location
Henderson,Ky. USA
Corvette
1978 Silver Ann. 2014 Red Stingray
The first of the year on my average m.p.g. display it was reseting itself before I would do it. I took it to the dealer because it was still under warranty and the only thing they could figure out was to change the instrument cluster. Didn't have any more trouble with the average m.p.g. information. Last week I went on a trip and wanted to check the mileage. After I had gone about 100 mi. I went to check to see how far I had gone and it didn't show but about 10 mi. . It showed the same thing to on trip A and B. I took it back to the dealer and they drove it 6 mi. and it was doing ok. They reset both the trip a and b and said to see what it does. I drove it for about 20 mi. and the trip a reset itself but b hasn't. Anybody else had this trouble:confused
 

XLR8

Gone but not forgotten
Joined
Jun 23, 2004
Messages
6,662
Location
Mississippi Gulf Coast
Corvette
2003 AE Convertible, 1998 LCRM Convertible
Strange.
I haven't had anything like that happen on my '98.
Good luck with it... and please be sure to post back here when it's resolved - in case it shows up on mine. :ugh

:w Jane Ann
 

gaC5

Well-known member
Joined
Sep 14, 2001
Messages
102
Location
Henderson,Ky. USA
Corvette
1978 Silver Ann. 2014 Red Stingray
:W I had a 98 coupe I bought new before my 04 and had about every electrical problem with it except that
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom