Welcome to the Corvette Forums at the Corvette Action Center!

P0410 errors, air injection check valves already replaced

Sharondippity

Well-known member
Joined
Aug 10, 2003
Messages
180
Location
San Jose, CA
Corvette
2001 Torch Red Coupe
My boyfriend is a mechanic for Mercedes, has worked on Porsches and every type of car out there, is now learning my car due to recent check engine light annoyances.

P0410 came up in December, I read the threads here, he checked the valves, one was fused closed, so he replaced those on both sides.

My car got hot yesterday driving home (idling for about 25 minutes in a nightmare traffic jam) and the light came on, same P0410 error code.

He wants to check the O2 sensors and do some elaborate testing.

I wonder what the next likely culprits are, to spare him some time.
 

c4c5specialist

Technical Advisor
Joined
May 29, 2001
Messages
3,682
Location
New Haven, Ct. USA
Corvette
Nope, but someday.
Hi there,
Simple start the car ice cold.
Listen for a humming noise coming from the lower drivers side headlamp.
That is the injection pump working.
If you do NOT hear it, you may have a blown fuse or a bad motor.
Very easy to check.
Allthebest, c4c5
 

wishuwerehere82

Well-known member
Joined
Sep 6, 2003
Messages
2,314
Location
Rochester, NY
Corvette
Red '82 Coupe,Sebring Silver '98 Coupe
Is that the sound that sounds like a turbocharger spinning up when the engine is idling?
Usually when I'm pulling into the garage?
 

Sharondippity

Well-known member
Joined
Aug 10, 2003
Messages
180
Location
San Jose, CA
Corvette
2001 Torch Red Coupe
My car keeps coming up with P0410 and is not able to pass smog due to this. I reset the check engine light and it keeps coming back on in a a day or two.

It's at the dealer, they have tested "everything" and cannot find anything wrong with it. Check valves replaced. O2 sensors check. Air pump checks fine.

Any hints or help will be appreciated.
 

c4c5specialist

Technical Advisor
Joined
May 29, 2001
Messages
3,682
Location
New Haven, Ct. USA
Corvette
Nope, but someday.
HI there,
Have them disconnect the steel pipes going TO the exhaust manifolds.
Then, they can turn the air pump on and make sure there is air coming out of the tubes.
If there isnt, chances are very high that either the vacuum solenoid is NOT opening up or the tubes are rusted internally, not allowing air to pass.
Allthebest, c4c5
 

Sharondippity

Well-known member
Joined
Aug 10, 2003
Messages
180
Location
San Jose, CA
Corvette
2001 Torch Red Coupe
HI there,
Have them disconnect the steel pipes going TO the exhaust manifolds.
Then, they can turn the air pump on and make sure there is air coming out of the tubes.
If there isnt, chances are very high that either the vacuum solenoid is NOT opening up or the tubes are rusted internally, not allowing air to pass.
Allthebest, c4c5

Light came back on, and this time when I took it in they found that the solenoid was faulty.

You were correct.
 

navy2kcoupe

Well-known member
Joined
Dec 16, 2006
Messages
799
Location
West Central FL and SE Mass.
Corvette
2000 Navy Blue Coupe A4 Z51
Sharondippity, thanks :) for posting the fix and closing out the thread. It sure is nice to be able to follow a problem all the way to the conclusion.
Andy :w
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom