Welcome to the Corvette Forums at the Corvette Action Center!

Help! performance/cooling

Lippy

New member
Joined
Nov 22, 2015
Messages
4
Location
Riverside Ca.
Corvette
1986 Corvett Gray/Black 2 tone
My 84 seem to be running fine, the temperature running between 185 & 220 most of the time. the ambient temperature is 95 to 105.
I drove the car approx. 200 plus miles no problem. When I started driving on the streets the car started to run a bit warmer at approx. 225 to 230.
I stopped to get a drink and when I tried to start it again it would not run I noticed the temperature was at 233, I let the car cool off to approx. 214 the engine started and was running I want to believe normal but I noticed the temperature was fluctuating up and down 5 to 10 degrease, also noticed an smell like chemical or burnt varnish in the car. This same thing happened a week ago and I thought maybe the cat was plugging, so I had to have the car smoged and the 02 emission's were too high so I had it checked and the cat replaced. I didn't get the smog test done because the engine stalling I didn't think it was a good idea. Has anyone ever had something like this before?

Please help :W:confused
 
Last edited:

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Advertise with the Corvette Action Center!

Double Your Chances!

Our Partners

Top Bottom