Welcome to the Corvette Forums at the Corvette Action Center!

So EAGLE!!!! It's in!!!

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
So I scored a Hypertech Thermomaster chip from Eagle for a SONG!

And he shipped it to me FIRST without payment.. ( trusting soul )

It just got stuffed in! With the Reman ECM from Mid America.
( 20 minutes.. piece of cake )

So here's the deal

Well I didn't see God from the blackout from pulling to many G's

But

About a 5-7% increase in hoserpower.

Idle's the SAME ( smooth ).

Fan come's on @ 180 ( Main ).

Shift's a tad firmer.

Ping's JUST a touch ... gotta back my timing off 2 deg ( so 4 deg BTDC )

So TADA!

Now the science projects of the week

This did NOT fix my .......

No main fan on A/C request issue.
( Back to the drawing board on that one)

AND

I've gotta figgure out what the diff is between this 89 Auto chip ( NON CA )
Part # 128982 and the correct 88 Auto chip
Part # 158331...

And it starts SMOOTH... before it would crank 10 times before she would light.. now it seems like 3-4...

Last week, I disconnected my Cold start valve @ the sensor.

When this was hooked up It took 15-20 cranks before she would light and would BELCH a waft of premimum fumes out the back... ( Ah the joys of remote start ).


SO THANKS EAGLE...... You DA MAN!

( I dropped the check in the mail this morning)

Vig!
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
No really

I put the check in the mail THIS MORNING!

And my Corvette IS PAID FOR!


Vig!
 

Baldie88

Well-known member
Joined
Mar 14, 2002
Messages
551
Location
Waterloo, IL USA
Corvette
2016 triple black vert.
For your no main fan when the AC is turned on you might want to check the high pressure switch. It's the smaller of the 2 switches on the line. I've also got an 88 and that's what fixed mine. There's a shrader valve under the switch so you don't lose the charge. Only problem was keeping the o-ring on when seating the switch because the small amount of freon that leaked putting on the switch kept pushing it out of the way. Eventually got it on though. :)

Good Luck
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
You read my mind!

I called my local parts store... they are ordering it as we speak!


Vig!
 
S

Shadowing1985v

Guest
takes 10 times to start your car?

or did i read this wrong?


if so, then tune port injection should start up so easy
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
FYI

"before it would crank 10 times"

Clarification

10 rotations of the crank
 
E

Eagle85C4

Guest
I knew you would like the change....nice kick in the pants huh!

Now if I can just get rid of these hypertech stage 1's for the 85....
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
Another OH BY THE WAY!

So on the dash of an Auto Tach is the Odrive light..... In the begining it NEVER came on...

Guess what...now it's stuck on.....

I believe it's an indicator problem ONLY and I have been tracing this down for a while!!!!!

It's not a problem...just something different.


Vig!
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom