Welcome to the Corvette Forums at the Corvette Action Center!

the starters trying!!!!!!!!!

British Bob

Well-known member
Joined
Oct 10, 2002
Messages
112
Location
England
Corvette
1986 Black C4 Convertable
Hi,

The other day as mentioned in a previous thread I ground to a halt on a main road and had to be towed home.

Installed a new fuel pump and the car started up first time. Great!!!!

Left the car for about four days and put the battery on trickle charge.

The battery should have had full power and i think that it is fine however when I turn the key the starter motor (which is two years old) clicks and doesnt quite turn the engine enough to start it, there is a whining sound when it is not turning in between the clicking noises.

The car will bump start first time every time and once running is fine..

Is it that the battery is just not up to the job anymore or are the above symtoms old news to anyone.

Cheers in advance

BB
 

G Winter

Well-known member
Joined
Aug 21, 2004
Messages
2,177
Location
NW Iowa
Corvette
1990 red convert 6 sp
First thing to do is clean all connections, on the battery and to the chassis.If this doesn't do the trick have the battery checked. The way you discribe the problem it sounds a lot like bad connection.

Glenn
:w
 

British Bob

Well-known member
Joined
Oct 10, 2002
Messages
112
Location
England
Corvette
1986 Black C4 Convertable
hi guys,

THANKS VERY MUCH , IT TURNED OUT THAT THE BATTERY WAS DEAD AND UN CHARGABLE

More spending required.

Its like having an expencive wife.

Cheers again

bb
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom