Welcome to the Corvette Forums at the Corvette Action Center!

vacuum lines and lean code

jseremba

Well-known member
Joined
May 16, 2013
Messages
53
Location
Toms River, NJ
Corvette
1989 Blue Z51 6 spd Manual Transmission
hi everybody


I own a 1989 Z51 6 spd. The car is back firing. The code according to my mechanic is something about running lean. I have the hoses on the top of the canister running correctly. The CEL is on and it now wants to stall.
Does anyone know what the lower hoses connect to. I met someone with a pristine 87 and I did not want to start climbing all over his car. The lower hoses go into the front bumper but I do not know what they connect to.
If I leave the hose from the manifold to the canister off the car will idle. I would like to connect it properly. So if anyone knows where it goes please email me.
If anyone knows what i need to do to get rid of that code


Thank you all
 

DonB

Well-known member
Joined
Mar 25, 2015
Messages
339
Location
Chicago
Corvette
2019 ZO6 in Elkhart Lake Blue
Sounds like you have a pretty good vacuum leak somewhere.
 

jseremba

Well-known member
Joined
May 16, 2013
Messages
53
Location
Toms River, NJ
Corvette
1989 Blue Z51 6 spd Manual Transmission
Sounds like you have a pretty good vacuum leak somewhere.

Well what I did was connect everything the way the 1987 was set up. And, The CEL went out. But, the cars drive ability has gone to hell. It idles at 600 rpm and goes as low as 400 and STALLS!! YUCK! I dropped it off at my mechanic. I am thinking TPS? Timing?
Actually the car idled fine. Was at 700 RPM. I started to drive it and when I got to a stop sign or light it went down to 400/500 and almost stalled. But, at least the CEL is out.
All of my passenger side signals and parking lights are not working. I have all new bulbs they did work. I think a wire fell on something. So, right now my cornering lights and console lights go on when I press the brake pedal. I think it is a short and when the brake gets depressed the switch acts like a ground. And my hatch, cigarette lighter and cruise do not work. Again I think I have a short. No blown fuses. Got to get some time.

Thank you all for your help.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom