Welcome to the Corvette Forums at the Corvette Action Center!

72 won't start in park, auto-trans short?

jamgrass

New member
Joined
Aug 10, 2007
Messages
3
Location
nashville
Corvette
1972 Coupe
Kind of hard to describe in subject or a search, but I did try and look thru the threads to see if others have come across this.

My 72 has always had a short of some sort and the auto transmission gearshift used to have to be jiggled into park several times to engage the circuit and allow it to start.

I have looked and can't seem to find out what it causing the short, wondering if others have encountered this problem, and hopefully provide a solution or a workaround.

72 coupe 350 all original.
Thanks folks!
Phil
 

KANE

Moderator
Joined
Mar 2, 2002
Messages
3,244
Location
KY
Corvette
Dark Blue 1982 Trans Am(s): Polo Green 1995 MN6
Kind of hard to describe in subject or a search, but I did try and look thru the threads to see if others have come across this.

My 72 has always had a short of some sort and the auto transmission gearshift used to have to be jiggled into park several times to engage the circuit and allow it to start.

I have looked and can't seem to find out what it causing the short, wondering if others have encountered this problem, and hopefully provide a solution or a workaround.

72 coupe 350 all original.
Thanks folks!
Phil

It sounds like you may have a bad neutral safety switch. It looks kinda like this and is located next to the gear shift. You'd need to take the console apart to get to it.

images
 

Phill

Well-known member
Joined
Apr 20, 2007
Messages
216
Location
s.florida
Corvette
1979 Blk L48
ditto on the neutral switch. if your tring to find it in the repair manual i believe they call it a backup switch(i think).
 

jamgrass

New member
Joined
Aug 10, 2007
Messages
3
Location
nashville
Corvette
1972 Coupe
http://www.1aauto.com/1A/NeutralSafetySwitch/Chevrolet/Corvette/1AZNS00701/380424

I looked up the part, and it says mounts on steering column. That seems odd to me.
Def. the neutral switch as I was also having intermittent reverse light issues. Is there a relatively easy way to just bypass it? I can't get it to start at all now and would like to work around until I can order the part and manual to see how it's installed.

I looked under the console and didn't see anything looking like either the pic darkshark posted or the one in the link above. Any help very much appreciated. Thanks folks, Phil
 

Phill

Well-known member
Joined
Apr 20, 2007
Messages
216
Location
s.florida
Corvette
1979 Blk L48
you could be looking up the part for a manual transmission, i believe they do go on the column. i looked on the ecklers web site and the switch, although its not the same part number, looks just like mine. ecklers part # 32621 this is for a 72 w/auto trans.
 

jamgrass

New member
Joined
Aug 10, 2007
Messages
3
Location
nashville
Corvette
1972 Coupe
thanks for the part #. I think you are right.
Still wondering if anyone has a clever workaround.
Cheers, Phil
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Advertise with the Corvette Action Center!

Double Your Chances!

Our Partners

Top Bottom