Welcome to the Corvette Forums at the Corvette Action Center!

Help! '93 won't *%$#@ start!!!

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
My 93 won't start. It wants to turn over...
It's been sitting for about 6 mths..battery was disconnected.
Connected a new battery, all the bells and whistles light up, stereo plays, alarm works, windows go up and down... but the Vette won't turn over.
Got some STP octane booster... think this'll help? I was thinking that maybe the fuel degraded.
 

93Rubie

Well-known member
Joined
Jul 19, 2009
Messages
777
Location
PA
Corvette
1993 Ruby Red 40th Anniversary Coupe
Cranks but NO start. Pardon he pun but start with the basics. Check for spark, fuel pressure, etc...I doubt you have a base engine problem if it was running before. I would start with fuel and ignition and go from there.

Do you smell any fuel when cranking or can you hear the fuel pump turn on, when you turn the key to on/run?

Spark can be checked by pulling plug wire and installing a spark tester.

Any codes?
 

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
Thanks for the response, 93Ruby!
I'm getting that 'SYS' flashing on the dash now.
Other than that...no codes.
I do hear pump when I switch the key to 'On'.
It's firing...just won't turn over.
 

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
....sorry... 93Rubie! I was trying to look under the hood and type in between!!!:L
 

vee93

Well-known member
Joined
Nov 15, 2002
Messages
585
Location
Mississippi
Corvette
1993 Medium Quasar Blue Metallic Coupe
...so is it safe to put in the octane booster or not?
 

93Rubie

Well-known member
Joined
Jul 19, 2009
Messages
777
Location
PA
Corvette
1993 Ruby Red 40th Anniversary Coupe
I would not bother with the octane booster, as it will not help any. Probably won't hurt anything either, if you pore it in. So is it sputtering or just cranking and not even trying to start?

Just a SYS light? NO security lamp?

IS it flashing?

You may have a code stored in the CCM. Central Command Module.
Which may or may not be related to your trouble.

For grins and giggles pull off your fuel injector covers and see if any critters chewed on any wiring.

I would still explore the basics first and go from there. Spark, Fuel, Air, Compression. With Spark and Fuel being first.
 

Robertwav1

Well-known member
Joined
Jan 7, 2003
Messages
819
Location
Ocala, Florida
Corvette
1993 Blue
Hey that "sys" light has something to do with or could do with the battery voltage...I would definitely check that. Maybe a bad cell or somthin'. That car does not like inadaquate voltage.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom