Welcome to the Corvette Forums at the Corvette Action Center!

Blower Motor Hi Speed

Joined
Feb 25, 2003
Messages
887
Location
Clarksville, Tennessee
Corvette
1979 Bright Red L-82
My hi speed switch does not work......where do I start to look. All the other speeds do work.
 
B

bmotojoe

Guest
If the 79 is wired anything like the 77 there could be two different possibilities. There is a relay bolted on the (center) right side engine compartment of the firewall. Unplug the connector and check the red wire with a meter or test light to a good known ground. If you have voltage there then the relay is bad or may be a dirty connection. If there is no power on the red wire of the connector then follow that red across the firewall down below the brake booster I think the high speed fan relay fuse is there. It is a 30 amp fuse that powers the high speed fan relay that you just checked.
Now these suggestions are from a 77 wiring diagram so I may be way off here.
Brian
Here is a pic of what to look for:http://www.ecklers.com/product.asp?pf_id=27456&dept_id=1122
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
If the 79 is wired anything like the 77 there could be two different possibilities. There is a relay bolted on the (center) right side engine compartment of the firewall. Unplug the connector and check the red wire with a meter or test light to a good known ground. If you have voltage there then the relay is bad or may be a dirty connection. If there is no power on the red wire of the connector then follow that red across the firewall down below the brake booster I think the high speed fan relay fuse is there. It is a 30 amp fuse that powers the high speed fan relay that you just checked.
Now these suggestions are from a 77 wiring diagram so I may be way off here.
Brian
I'd say your right on track!! Also it could be the fan switch in the console!!:upthumbs
 
B

bmotojoe

Guest
Also it could be the fan switch in the console!!:upthumbs

GOOD CALL! I knew I would forget something
To check the switch put it into the high speed position and check the pink wire on the connector plug at the relay. You should get a light or voltage there if the switch is good.
Ignition switch has to be on.
Brian
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom