Welcome to the Corvette Forums at the Corvette Action Center!

charging system

S

ss_slayer

Guest
ok, here is the thing, i have an 81 automatic vette, i bought a new battery, and is not getting charged, i replace the alternator but this didn't solve the problem. what other things sould i look?
 
Joined
Apr 8, 2005
Messages
274
Location
Charleston, SC
Corvette
1981 Dark Blue Metallic, 2003 AE coupe
SS,

Sounds a little tricky. If you can get the car running, take a gander at your voltage meter and see if it''s putting out at least 14 volts. To me, that would indicate that your alternator is putting out just fine. I'm not sure if these cars have a separate voltage regulator or not. Sometimes they're integral to the alternator and on some cars, they're a separate unit. You don't mention how long it takes to drain the battery down to where the car doesn't start. Mine seems to drain down if I don't start her every two weeks. I don't know how old my battery is though. There could be load on the battery when the car sits that's causing it to drain, so check for any lights that may still be on inside the car and verify the under hood light goes out with the hood down. The battery itself may be grounded in its compartment. If there is a lot of residue from years gone by as evidenced by a build-up of white chaulky substances under and around the battery, then disconnect the battery and remove it. Then clean out the compartment with a mixture of baking soda and water. Also clean up the outside of the battery case. This will neutralize that acid residue and remove the path to ground from your battery to the frame. Dry everything real good before replacing the battery. While the battery is out, it might be a good time to put it on a slow charge before reinstalling it. Good luck. Maybe someone else can chime in with some ideas.

Mike:w
 
Joined
Apr 29, 2001
Messages
2,141
Location
Rio Rancho, NM
Corvette
1981 HD Suspension; ZN1 Option
ok, here is the thing, i have an 81 automatic vette, i bought a new battery, and is not getting charged, i replace the alternator but this didn't solve the problem. what other things sould i look?

In my case it was the vanity mirror remaining "on" even with the lid was closed.

GerryLP:cool
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Win Both Corvettes!

Win Both Corvettes and Get Extra Bonus Tickets Now!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Dead Center Foundation

Vetteskins

Advertise with the Corvette Action Center!

Partners

Top Bottom