Welcome to the Corvette Forums at the Corvette Action Center!

Cruise Control Not Working

R

rbell@idtfla.com

Guest
Any Help appreciated. The Cruise control on my 81 does not work at all. I turn it on and not light in the dash appear nor does it do anything. Where should I start. I have the shop manual but really did not make much out of it.

Thx,

Bob
 

Peer81

Well-known member
Joined
May 21, 2003
Messages
2,497
Location
Netherlands
Corvette
'81 Black
Hello Bob,

The cruise control works without showing it through a light or something else.
Its a old system so it doesn't work like modern cruise controls. So you have to set the cruise control then push the button on your lever and slowly release it. When this doesn't work check your cruise control, its on the left side behind the wheel fender (behind / below the wiper reservoir). Check if all the connectors and vacuum lines are there in the correct order. Also check where the vacuum is coming from, if the course is oke. Check if the connector from the vacuum "can" to the gas lever is correctly attached. Also don't forget to check the switch at your brake pedal! Then if every hose holds his vacuum try to take out the cruise control to look at the internals.
There is a great side to see how it should work:
http://iotech.no/corvette/technical/corvette_cruise_control.htm
Good luck,

Groeten Peter.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom