Welcome to the Corvette Forums at the Corvette Action Center!

Help The New Guy Here! Loss Of Power!!

P

psychomatica

Guest
Hello all, I have a few problems I hope the many people that are smarter than I can answer:

CAR: 1990 red vette with the L98 w/ 38000 miles

car sat for 2 years

here are the problems:

#1 CAR HAS SEVERE LOSS OF POWER, idles rough and gets terrible gas milage,..will not spin the rubbers at full throttle either,..my rpm's in o-drive drop to approx 400 and can get lower(this is with everything off(stereo/ac/)---as well as there is a SERIOUS HESITATION at the point of acceleration(it falls on its face!!--I have no error codes at this time(except for the abs light but i'll get to that!)

Heres what I have done:

changed the oil,oil filter,air filter,fuel filter,plugs,wires(8mm)
checked all vacuum lines,checked all the cats(by professionals)all good.serviced the fuel tank with two doses of chem-tool...changed the trans fluid and trans filter as well..

-----------------------------------------------------------------------

#2 SERVICE ABS light is on now

heres what i have done:

serviced the brake boosters(two)
disconnected the battery for 5 min to alow the code to be removed...no luck

----------------------------------------------------------------------------

#3 POWER DOOR LOCKS not working at all!,..wires are connected but i cant find the fuse for them *QUESTION* is there more than one fuse block on a 1990?, If not which fuse is it?,..none of them say " door locks"

------------------------------------------------------------------------------

#4 TRANSMISSION OUT OF ADJUSTMENT? my transmission acts a little odd,..when driving, the orange marker on the console lines up well above the letter its supposed to center on and when i put it in reverse its not even to the R (between park and reverse letters),..when its like this (it only does this about 50% of the time) the car will not lock into park and will roll.

it seems like the transmission is slightly out of adjustment??

Well I know that this is a lot of questions for a first timer but I know you guys can sort me out.....

Also do any of you folks know where can get a 1990 airbag cheaper than 300/400 clams..

Also if any of you are close to San Fran please let me know.!!!!:)
 

BigRed

Well-known member
Joined
May 23, 2001
Messages
948
Location
Edmonton
Corvette
1985 Bright Red Rocket
On Number open the hood and start looking for Vacuum leaks is my first suggestion

Two sounds like a GM dealer problem (May be the Pump)

Three Do your Courteousy Light inside work? If not keep hunting for the fuse. If so it could be Alarm or something else which someone with VATS would have to help you with

Four Hows the fluid Level/Color/Smell when was the last time you changed your fluid (sounds like your Automatic there)
 

Ethan

Well-known member
Joined
Jul 14, 2001
Messages
68
Location
Elgin Tx. USA
Corvette
1991 L98 Coupe
aic

Sounds like the idle air control valve could be gummed up or sticking in the throttle body. Also could be oxygen sensor.And finaly check your fuel pressure should be around 40 to 45lbs with vacume on it.
 

vigman

Motor head!!!!
Joined
Feb 13, 2001
Messages
3,471
Location
Valencia, CA,USA
Corvette
88 Convert ( SOLD ) /1973 coupe 4 speed/1964 Vert!
Tranny & others

Your shift cable is busted at the mount point by the tranny.. the place where the crimp attaches to the cable has come loose.
( Common problem) Jack it up... put blocks under the car ...crawl under.. have some body move the linkage...you will see it.

The power door locks is not a fuse but a circut breaker.... in the fuse panel PWR ACCY 30 amp. Check this first.

Service ABS... there is a way to poke the codes for this.... get a scanner.

Lack of power... could be plugged cats have a simple back pressure test done ( $35.00 ).


Vig!
 
S

Shadowing1985v

Guest
u don't need a scanner for 1985 vetts

scanners are only used for like,, 1994 vetts and up,, cuase all u have to do, is buy a book on corvettes from your local auto place,, and it will have what your codes mean,, and tell u wha tis wrong,,, now all u have to do is take a wire,, and jump your dynositc termal,,, and ground it out,, the book shows u how to do this,, and your engine light will flash and how many tiems it flashes gives u the codes,,, alot of people dont' know this, u can do this on,,, most cars,,,


anyways,, it sounds like u are having the same problem as me,,
i have done alot since though,,, i have replaced my ECM and my ICM. the ICM was the problem i think,, u might want to look at that,,, if u can start your car and pull up a spark plug by the distributor, with out getting burnt,,, from a powerful spark,, then your ICM is bad,,, right now i just bought a timing lite,, so im going to time my car out,, and never mess with the timing settings again,,, if that doens't fix my problems,,,,(which is) "rough idle,, sounds like it is missing,,all the time,,poor accerlation", i have replaced every snesor and senoild u can think of accept my idle air control (which that one dude gave me an idea that,, might be wrong,, i always thought about it just rencently, but i fhe thinks that might be something , then i will check it out,,, also, i could use some spark plug wires, hehe,, other then that i have changed every thing,, anything that is comptuer,, just everyting, u think of it it has been changed out,, brand new,,, accept the mass air flow sensor i didn't change that,, (is it possiable for your mass air flow sensor be working but not working the right way, anyone know that one?), anyways if that all doens't work im going to check my injectors,, run a pressure tester on it, im just going to go buy one i guess, for 30 bucks or so,, and see what im reading,, it used not not even beable to spin the wheels from take off,, same problem as u describe but now, i can spin my wheels,, when i replaced the icm, but when i first bought it i used to beable to go 40 mph down the road and floor it and my back wheels woudl spin,,it was that bad ass, the 85 corvette is just fast anyways,,, few people know it,, its one of the fastest model in the 80's they claim,,
 
S

sothpaw

Guest
If you tuned it up yourself,
make sure you adjusted the
timing correctly.
 

Ethan

Well-known member
Joined
Jul 14, 2001
Messages
68
Location
Elgin Tx. USA
Corvette
1991 L98 Coupe
Timing

Make sure you disconnect timing connecter per emissions label or you will be advancing it 10 to 15 degrees plus the initial setting.
 
P

psychomatica

Guest
WELL THE DIAGOSIS IS IN!!

Hey all I took my 90' to a performance shop to have it looked at!,...heres what they found chime in and let me know your thoughts:

#5 injector BAD!(or clogged, broken ect)
#2 injector intermittent
#8 injector intermittent
O2 sensor fail
O2 heat#1 sensor fail
O2 heat#2 sensor fail

all in all i am looking at approx 500.00-700.00
to get it up to speed!

but all is well when i stomp on the gas and all i hear is sqeals!!!!

p.s. howdo i get the wacky-ass faces?(ie; sloshing the beers,drinking the brew ect)
 

Edmond

Well-known member
Joined
Aug 1, 2001
Messages
5,218
Location
Louisiana
Corvette
2003 Z06
So for $500-700, they'll replace all three O2's and clean out the fuel injection system? Or is it that they'll replace injectors?

Either way, that sounds like a very reasonable price for that kind of work. I say go for it and let it rip.

As for the wacky faces, when you reply, there is a little blue thing that says "clickable smilies", just click on that and the screen will pop up.
 
S

Shadowing1985v

Guest
hmm. well shoot

maybe my car has the same problem
im taking out my injectors tomrorow,,,


alreayd got it tore down to the,, fuel rail
i don't have a fuel pressure tester

i was just going to clean my injectors,,
i wonder if a local auto place can test out injectors,,
what my car is doing is

the gas pedal is spungy
its a 85
and i mean is,, at first,, when i started,, my car woudln't even pill out,, had no juice,, so i replaced alot of stuf that didnt need to be replaced,, finally i replaced my ICM and that was the problem,,, but,, my car still doens't seem to be taking off like it should,, my back end will spin just a little now,,, when i bought it 7 months ago,, i used to beable to go liek 40mph and floor it and my tires would spin,,, doens't do this anymore,,, so maybe, my injectors are bad,,, sigh,,
 
S

Shadowing1985v

Guest
O2 heat#1 sensor fail

O2 heat#1 sensor fail
O2 heat#2 sensor fail


what are those sensors,,
i dont' remember seeing those sensors,, on my car,,

i own a 85,, it should have the same sensors as the 90,, hmm

where are those located at,,,
 

69MyWay

Well-known member
Joined
Jul 3, 2001
Messages
4,364
Location
Auburndale, Florida
Corvette
1969 Killer Shark
The 90 only has ONE O2 sensor.

You problem sounds so much like a bad CAT. Sometimes they test out okay, but until you cut them off the car and look inside you can't be 100% for sure.

The inner portion breaks up and will start to rotate in the mass of material in there. It is like sticking a sock up the tail pipe and trying to drive. It will still drive, but no power, intermitten power, and certainly it will struggle at higher RPM.

Been there done that too many times to care now. The way the Cats are made, they don't have to have many miles on them to fail. The age of the car alone puts you in a high risk bracket.

I have 150K plus miles on the injectors in my 90. They rock! And, I am pushing them to the extreme with the hot rod engine and intake they are sitting on top of. I think injectors get replaced all too often when there is nothing wrong with them.

I would start out by spending the $800 on a fresh CAT system under the car.

You need to buy a 1990 G.M. service manual. It has very important information that will help you better understand why your ABS light, etc has come on, and the EXACT procedure for turning off the light. The 90 model is nothing like the 85-89 in terms of the electronics. You have a secondary onboard computer called a CCM that stores info including the mileage, current/historical codes, etc. It is the half breed cousin system to the now common OBDII computers.

Trust me on this one, and you will be very happy with the results. Plus, if you replace them and there is no improvement, it is at least one thing you can rule out that won't happen anytime soon. (the CATS that is).
 

Edmond

Well-known member
Joined
Aug 1, 2001
Messages
5,218
Location
Louisiana
Corvette
2003 Z06
So it's settled? The CATS first? Chris, did the 90's have the little pup cats and then the main cat like my 88'?

O2 sensor should make a difference, it did for me. You'll really notice a difference in throttle response from a new O2 from a bad O2. It's actually an inexpensive part that can be done at home in less than an hour. I paid $30 for mine at Pep Boys.

It should also be safe to let you know that you'll need a pair of Rino Ramps. I'm not trying to plug that product, but they work and last I saw, they were on sale at Pep Boys for $25 so go for it!
 

69MyWay

Well-known member
Joined
Jul 3, 2001
Messages
4,364
Location
Auburndale, Florida
Corvette
1969 Killer Shark
BullWinkle said:
So it's settled? The CATS first? Chris, did the 90's have the little pup cats and then the main cat like my 88'?

O2 sensor should make a difference, it did for me. You'll really notice a difference in throttle response from a new O2 from a bad O2. It's actually an inexpensive part that can be done at home in less than an hour. I paid $30 for mine at Pep Boys.

It should also be safe to let you know that you'll need a pair of Rino Ramps. I'm not trying to plug that product, but they work and last I saw, they were on sale at Pep Boys for $25 so go for it!
Yep, the 90 also has the two precats, then the one large one under the belly. I have seen cars pass emissions exams with only the center cat and a well tuned engine.

I am learning more and more the value of a scanner instead of just the old paper clip and code guide. If the new cats don't fix this car, I would like to see what kind of readings it produces through a good scanner.
 
S

Shadowing1985v

Guest
wow

im still trying to figure out what is with the 2 extra o2 sensors,, the scanner was talking about


anyways,, two small cats before the big one???
does my 85 have that,, as well,,

i dont' remember seeing that,, i would think it would be noticeable,,

anyways this is what i did,, its really illegal, but oh well, my dads frine inspects my car so he doesn't check if my cat works or not,, hehe,, wha ti did was, i took off my cat and knocked out all the stuff inside of it,, hehe,, so i pretty much have no cat now. but i might go buy one cuase it does put some fuel out my tale pipe, that doens't look very good,,
 
S

Shadowing1985v

Guest
Sigh..

Does my 85 have two precats???


im going to put it on the lift and look

i dont' remember seeing anythin like that,,
 

69MyWay

Well-known member
Joined
Jul 3, 2001
Messages
4,364
Location
Auburndale, Florida
Corvette
1969 Killer Shark
Your 85 has one O2 sensor, and one CAT. The O2 is up on the Y pipe on the driver side I think just below the driver manifold. The CAT is dead center of the car, and on the 85 model it will bolt on and off, so you can remove it without going to a muffler shop (after you get the heat shielding out of the way).
 
S

Shadowing1985v

Guest
hehe

yeah ,, i have my own shop, hehe

i was just wondering if i had two precats cuase i don't remember seeing them,, hehe,, my o2 sensor has alreayd ben recently replaced, all sensors in my car has,, my car is like 100 percent brand new now.. almost fully restored
 

-=Jeff=-

Well-known member
Joined
Feb 2, 2001
Messages
909
Location
Bartlett, IL. (Chicago Suburb)
Corvette
1990 ZR-1
Re: WELL THE DIAGOSIS IS IN!!

psychomatica said:
Hey all I took my 90' to a performance shop to have it looked at!,...heres what they found chime in and let me know your thoughts:

#5 injector BAD!(or clogged, broken ect)
#2 injector intermittent
#8 injector intermittent
O2 sensor fail
O2 heat#1 sensor fail
O2 heat#2 sensor fail

all in all i am looking at approx 500.00-700.00
to get it up to speed!

but all is well when i stomp on the gas and all i hear is sqeals!!!!

p.s. howdo i get the wacky-ass faces?(ie; sloshing the beers,drinking the brew ect)

Like 69myway said.. only one O2 on the 1990 model.. I also agree that the cat could be clogged. But what i want to know is what did they do to check the injectors. the Injectors if bad could cause the cat to go bad by flooding fuel to it.

I would suggest taking an Ohm meter and ohming across the 2 pins on each injector (while the injector is disconnected from the harness) My rule of thumb is any injector ohming out under 12ohms is bad. you can then buy a set of Ford SVO injectors for $220 approx, do the swap yourself, if you are handy and be don't

Yes the Ford injectors will work.. I am running 30# SVO injectors on my car currently
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom