Welcome to the Corvette Forums at the Corvette Action Center!

High Idle

barrier5

Well-known member
Joined
Dec 27, 2001
Messages
126
Location
janesville wi usa
Corvette
1982 bright blue coupe
Happy New Year All,OK heres the problem,I have a 1982 Corvette with no fast idle when cold.The heads have been done,new,IAC motors,EGR,Temp sender,vac.hoses etc.I just had new paint done and when I went to pick the car up it wouldn't run so we got a Tech I and ended up putting a new ECM in it too.Also tryed a different PROM,still no high idle,but the engine does run rock steady at 450 rpm now.I was looking a part called the ECell module but have been told that it doesn't control the high idle function,but in the Charles Probst on Corvette fuel injection he calls the same piece a cold start module so now I am totally confused.So any ideas out there would be welcome.Thanks
 

topless82vette

Well-known member
Joined
Nov 1, 2001
Messages
910
Location
southern california
Corvette
1982 convertible (not factory) stock 350cfi auto
our 82 did this too, was the coolant temperature switch mounted on the front of the intake has two wires going to it
 

barrier5

Well-known member
Joined
Dec 27, 2001
Messages
126
Location
janesville wi usa
Corvette
1982 bright blue coupe
I should of been clearer,that sensor was changed and not the temp.sending unit
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom