Welcome to the Corvette Forums at the Corvette Action Center!

Installed new opti-spark in 92 base corvette and now won't start

Raylicker

Active member
Joined
Sep 5, 2020
Messages
31
Location
Beaverton Oregon
Corvette
92 base corvette
How did you check the ground,Test Light or VOM?
I had a White 94 6 sp that gave me fits like this a few years ago (probly 8-10 years now) that I had all ready to deliver to a new owner and it just quit, after I replaced the Opti, ICM, Coil, Plugs and Wires still No start.Tom even sent me his back up 94 ECM because I thought mine was bad but that wasn't problem. Still NO GO! I've been looking for the thread to see what I finely found to get it running. (I've had 2 Hearty Acks and a mild stroke since then) This new software that Rob installed on the site is completely different and I can't find the thread it was in. I'll get in my files in the office and find the jacket to the car and find out for sure what I did,I've sold probly 250-300 or more cars since then. Stand By!


I tested with A VOM with ohms.
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
I found it,It was way back in 07. The gang grounds on the back of the engine left side 2nd bolt up on bell housing. 6-7 wires. Replaced 3 eye connecters and cleaned the rest,R & R'ed the bolt stud in the bell housing cleaned, re-installed and hooked it back up! I'm surprised I didn't remember the gang grounds on the back of the block. God knows I've cleaned 100s of them.............
PS You may have to remove the cats to get to it!
 
Last edited:

Raylicker

Active member
Joined
Sep 5, 2020
Messages
31
Location
Beaverton Oregon
Corvette
92 base corvette
I found it,It was way back in 07. The gang grounds on the back of the engine left side 2nd bolt up on bell housing. 6-7 wires. Replaced 3 eye connecters and cleaned the rest,R & R'ed the bolt stud in the bell housing cleaned, re-installed and hooked it back up! I'm surprised I didn't remember the gang grounds on the back of the block. God knows I've cleaned 100s of them.............
PS You may have to remove the cats to get to it!
This is a recap of my posting on another site
{Thanks to everyone that help but still no start, so let me recap events(2 corvette was running but poorly so I decide to replace optispark with one from Cardone. At the same time I decide to replace intake, timing cover, oil pan and valve cover gaskets and seals. Without going into details the new opti wouldn't fit flat so I transferred everything from new one to my old base and its fits on very nice. While doing all this I adjusted to valve lash by three different methods. well at the moment I have spark from coil and plug wires via spark tester, was only getting 20-# of fuel presser so replaced pump, now getting 40# with key on and 44# at crank and holds for hours, so I assume the regulator is fine no fuel smell from vacuum line. Yesterday I cleaned both ground points by oil filter. After fuel pump install it tried to start a little then got small backfire from intake. I double checked the opti on if I put it back together right and was fine and the spline will only go in one spot on the opti and one spot on engine but also has a spot that it will go in half way so I'm pretty sure its on right. Could the opti have spark and still be bad? Also pulled a couple of plugs and were wet. Don't know where to turn now so if any of you know someone on this board that might please lead then to me. I want my vet back}

Since then I took opti apart and then started having no spark. I have bought another opti {An AIP opti} a ICM and getting good readings from both ICM and Opti connectors, but then the service manual say's it a bad connection or connector

I cleaned those grounds once and today checked the ohms to battery ground and have .00. and the same for all grounds I checked. So you think I should change all connectors on that gang? You know after I cleaned those grounds that's when I started having the no spark. After opti install it wouldn't start that's when I found out the my fuel presses was less than 20#. After it wanted to start but back fired out the intake and couldn't get it started after.
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
"So you think I should change all connectors on that gang? You know after I cleaned those grounds that's when I started having the no spark. "

By all means,If thats when the No Spark started,I'd go over them and check again!
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
Should be a ground strap going from there to the chassis right behind the battery by the Air Bag Sensor.Make sure its in good shape too.
 

Raylicker

Active member
Joined
Sep 5, 2020
Messages
31
Location
Beaverton Oregon
Corvette
92 base corvette
I replace connectors on grounds down on the block and on bell housing and still no spark. I don't know what to do. Could it be the computer?
 

GWinter

Well-known member
Joined
Oct 2, 2005
Messages
70
Location
NW Iowa
Corvette
1990 conv. 6sp
I have never owned an opti spark but have found that a good battery is critical with todays electronics. Just something to consider. I assume the gas is not old.
 

Raylicker

Active member
Joined
Sep 5, 2020
Messages
31
Location
Beaverton Oregon
Corvette
92 base corvette
Well got it started, it was a f**king loose connector for the ignition control module, But anyway now I can only get it to run with starter fluid then it dies after about 45 seconds to a minute then it just dies. But thank you everyone for your help, but it just had to be something stupid like that. Any ideas on making it stay running? I have replaced the fuel pump and fuses are ok, so what else
 

Toms007

Moderator
Joined
Sep 24, 2004
Messages
6,473
Location
Southwest Kansas
Corvette
2007 Atomic Orange Coupe
I don't remember, did you check the fuel pressure at the engine? It was low, right? Then you replaced the fuel pump, correct? Did you check FP after that? Just sounds like FP issue to me. FPR could be not allowing enough FP.

Just grasping at straws here, but low FP is making sense here...
 

Raylicker

Active member
Joined
Sep 5, 2020
Messages
31
Location
Beaverton Oregon
Corvette
92 base corvette
Yeah I know I'll check that tomorrow. Yeah I replaced fuel pump and no gas out of FPR, heard it could be the relay
 

GWinter

Well-known member
Joined
Oct 2, 2005
Messages
70
Location
NW Iowa
Corvette
1990 conv. 6sp
I think those have a MAF sensor , make sure that is in place and connected, I have run into start but not run if that isn't right. A big air leak after the MAF can make them act really strange.
 

Raylicker

Active member
Joined
Sep 5, 2020
Messages
31
Location
Beaverton Oregon
Corvette
92 base corvette
Well i tested at the fuel pump and have 44# but nothing showing at the Schrader valve, would the regulator do that?
 

GWinter

Well-known member
Joined
Oct 2, 2005
Messages
70
Location
NW Iowa
Corvette
1990 conv. 6sp
most C4s have a fuel filter at the turn in the frame under passenger feet. Have you changed that?
 

Raylicker

Active member
Joined
Sep 5, 2020
Messages
31
Location
Beaverton Oregon
Corvette
92 base corvette
Well I got it started but real high idle so did some spraying with starter fluid and think the intake is leaking, That was something I replaced during this whole thing and think I nay have screwed up the back sealant by trying to lay it down by myself, Anything else it might be? It also runs like sh*t, a bad air leak would do that would it not?
 

Toms007

Moderator
Joined
Sep 24, 2004
Messages
6,473
Location
Southwest Kansas
Corvette
2007 Atomic Orange Coupe
Absolutely a leak like that can/will cause rough running.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom