Welcome to the Corvette Forums at the Corvette Action Center!

L98 runs bad in closed loop

B

billv

Guest
I bought a 90 6 speed convertible with headers, duals, and a GM HOT cam. The previous owner had a Crane cam w/ .575 lift and 240 dur., an LT1 intake with a custom chip. He then put in the current cam, and the TPI on with the chip for the old cam. He said all it would need is a new chip burned. I got a chip burned w/ all my specs, and it runs worse than with the other chip. It uses a Moates adapter. I put the stock Memcal back in, and it runs pretty well until it warms up, then it starts missing and popping through the exhaust.(It does this with all 3 chips) It is also running VERY rich, smoking. I set the timing to stock 6 deg., set the TPS, checked for vac. leaks, checked dist. Cap, etc. It has LT1 24lb injectors, and they check OK. Could the injectors be causing it to run bad in closed loop versus open if they were sticking or something? I’m running out of things to try. I’m thinking about putting the stock injectors back in and see if this helps. I know the fuel and spark aren't right, but it shouldn't do this. Anybody have any suggestions?
 
K

Key West Jack

Guest
what is fuel pressure? Did you check your O2 sensor.
 
B

billv

Guest
Haven't checked pressure yet, has stock regulator, previous owner said new Bosch O2 sensor last summer. He also told me the intake is ported, siamesed like on thirdgen.org, I haven't checked that out yet.
 
B

billv

Guest
Could a bad ignition module cause the backfiring only when in closed loop?
 

Lucs_Vette

Member
Joined
Mar 1, 2006
Messages
24
Location
Kemptville, Ontario
Corvette
1985 Black Coupe
Try the EGR valve, mine was doing the same .. try disconnecting it and putting a screw in the hose .. worked for me .. i will be changing the EGR valve over the winter .. at least it was a temporary fix.
 
B

billv

Guest
I don't have EGR because I have headers. I'll check to see if the valve is still there later, and if it is, block it off.
 
B

billv

Guest
Fuel pressure is 40 at icle, 43 at fast idle, 47 w/o vacuum at idle. I'm trying to use Datamaster, but it say error 2 when I test, version is correct. Any ideas?
 

SPANISHVETTS

Well-known member
Joined
Nov 5, 2002
Messages
1,143
Location
El puerto de Santa Maria Spain
Corvette
before 60,63&82 now 90 383 Stroker & 91 ZR1-Sold
Force it to stay in Open Loop and see how it runs. If it runs ok in Open Loop then look at the fuel management system. If it runs bad in Open Loop, which I bet it will, then you have a basic engine problem.

Check the ground circuits 3 times and then check them again. A Navy guy here spent over $1000 trying to fix his ABS without success. As a last resort we put in a new ground wire from the plug to the chassis and ¡VOILA! the light went off. He eventually found a broken wire in the harness by the right rear wheel.

Most of the problems with our cars are down to basics – it is just too easy to blame the problems on the newer systems which are 99% reliable.
:w
 
B

billv

Guest
UPDATE

I replaced the O2 sensor with a heated one, and it runs pretty good on the custom chip, though it still wants to stall a little when taking off if you're not careful. I sent the $35 cable off Ebay back, and he said a piece of solder was shorting 2 pins together. I should recieve it any day so I can try Datamaster again. I'm sure I will need some fine tuning of the chip.
I have a pretty good oil leak on the back of the motor, it looks like it is probably the rear intake seal, or possibly the oil sending block. Will a intake leak like this cause a vacuum leak?
 

scotch1

Well-known member
Joined
Feb 17, 2005
Messages
144
Location
Jackson,New Jersey
Corvette
1994 convert. 2002 C5 coupe
I'm not sure what you men by 'closed loop'?
How can I determine if my 1990 is in close loop,when it shouldn't be, as I have similar problems?
Tom.
 
B

billv

Guest
You can use a scan tool, or jump the A & B (top right pins) pins on the ALDL connector under the dash with the car running. If it flashes rapidly, about twice a second, it is in open loop. If it flashes slowly, about once a second it's in closed loop, when the oxygen sensor sends input.
 
K

Key West Jack

Guest
I replaced the O2 sensor with a heated one, and it runs pretty good on the custom chip, though it still wants to stall a little when taking off if you're not careful. I sent the $35 cable off Ebay back, and he said a piece of solder was shorting 2 pins together. I should recieve it any day so I can try Datamaster again. I'm sure I will need some fine tuning of the chip.
I have a pretty good oil leak on the back of the motor, it looks like it is probably the rear intake seal, or possibly the oil sending block. Will a intake leak like this cause a vacuum leak?

Will an intake leak cause a vacuum leak (loss of vacuum)? absolutly.
 

gmjunkie

Well-known member
Joined
Nov 11, 2004
Messages
4,547
Location
Old Fort NC/Vero Beach FL
Corvette
03 Z-51,78 L82 Coupe
I replaced the O2 sensor with a heated one, and it runs pretty good on the custom chip, though it still wants to stall a little when taking off if you're not careful. I sent the $35 cable off Ebay back, and he said a piece of solder was shorting 2 pins together. I should recieve it any day so I can try Datamaster again. I'm sure I will need some fine tuning of the chip.
I have a pretty good oil leak on the back of the motor, it looks like it is probably the rear intake seal, or possibly the oil sending block. Will a intake leak like this cause a vacuum leak?
My guess is it's the Oil sending unit,I've had to change them on almost every C4 I buy for resale,because of Oil Leaks!!!! As far as the O2 sensor I can believe that,I use "Only" AC Delco Genuine GM parts on sensors and Ignition parts!! And my customers Thank me for it,And so dose there car with Miles of Smiles from there owner!!!I've had allot of Problems Bosch,GP Sorensen,Tomco,Motor Craft,Wells,I will use Blue Streak Standard in a Pinch!!!
Besides I'm a "GMJUNKIE"!!!!!:lou :upthumbs
 

scotch1

Well-known member
Joined
Feb 17, 2005
Messages
144
Location
Jackson,New Jersey
Corvette
1994 convert. 2002 C5 coupe
Great, thanks. Tried it and found that my 90 starts in open loop, and then after a short time changes to closed loop, Interesting to note how long it takes to warm up a little.
Tom
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom