Welcome to the Corvette Forums at the Corvette Action Center!

Need some help

Lucs_Vette

Member
Joined
Mar 1, 2006
Messages
24
Location
Kemptville, Ontario
Corvette
1985 Black Coupe
Hi folks, me again .. lol

i have an 85 L98 with a 4+3.

Starts well and runs well, but i having a hard time figuring what might be causing the jerkness when driving at a steady speed (30, 40, 50 m/hr). when i eccelarate (hard) no problems, sometimes when i accelarate softly, she seams to hesitate. but the funny thing is .. is it seems to be worse on hot, humid days ..

Here is what i've done thus far,
- changed the plugs
- changed the wires (8.8)
- changed the distributor cap and rotor
- replaced the coil (on top of the distributor)

Not sure what else to try .. before i have to spend the big $$$ and take it into the dealer or shop. a friend suggested the Oxygen Sensor, fuel filter .. really don't know ..

anyone experience this?
 
T

tlong

Guest
Air, fuel, fire. It hasn't changed since the old days. Have you checked the obvious ...air and fuel filter? Changing those is maintenance anyway. You will have to stand by for more detailed suggestions as I have a 'modern' 1996.
 

larry bud

Well-known member
Joined
Jan 21, 2002
Messages
234
Location
Rochester, MI
Corvette
1986 "Speed Yellow" Coupe
Lucs_Vette said:
Hi folks, me again .. lol

i have an 85 L98 with a 4+3.

Starts well and runs well, but i having a hard time figuring what might be causing the jerkness when driving at a steady speed (30, 40, 50 m/hr). when i eccelarate (hard) no problems, sometimes when i accelarate softly, she seams to hesitate. but the funny thing is .. is it seems to be worse on hot, humid days ..

Here is what i've done thus far,
- changed the plugs
- changed the wires (8.8)
- changed the distributor cap and rotor
- replaced the coil (on top of the distributor)

Not sure what else to try .. before i have to spend the big $$$ and take it into the dealer or shop. a friend suggested the Oxygen Sensor, fuel filter .. really don't know ..

anyone experience this?

Since you listed what you worked on, are you sSure you don't have two plug wires crossed? If not, I would check to make sure they're all on firmly, and that spark is getting to each plug. If necessary, pull each plug and see if they've fouled.
 

John Robinson

Gone but not forgotten
Joined
May 3, 2005
Messages
1,555
Location
Muncie, Indiana
Corvette
1993 Polo Green Coupe
Try this

On a moonless night take the car out to a place that is dark. With engine running lift the hood and listen for a snapping sound. Or watch for an arc from the plug wires going to ground somewhere. Because you will be listening for the sound of a spark jumping it would be best if the place you pick is out in the country were it is quiet. :)
 

Lucs_Vette

Member
Joined
Mar 1, 2006
Messages
24
Location
Kemptville, Ontario
Corvette
1985 Black Coupe
Here is what the process was.

i first changed the sparkplugs with some degree of improvement, then a week or so later changed the distributor cap and rotor with a slightly higher degree of improvement , the third thing was the wires and coil (approx 3 weeks later), huge power impromvemen, it how feels and pulls like a vette should.

what has me confused is that the car starts very well, when it's cold the engine doesnt' seem to miss or sound like it's miss firing , when warmed up it seems to sound like it miss firing (unless it's my ear) and when driving it when engine is hot .. it seems like it i'm playing wth the gas pedal slightly and using up the play in the tranny, which i'm not. And i've found that on humid days it is worse then on a dry day.

- could it be the O2 sensor? which i'm changing today ..
- if it was the fuel filter the symptoms would be the same regardless of the engine being cold, hot, or the humidity levels.

what else could it be?
 

sriat

Well-known member
Joined
Feb 12, 2006
Messages
82
Location
Kansas
Corvette
1984 Bright Red Coupe
THis may be stupid, however I had the same feel as you described when my AC compressor was pulling because it had weak charge. Might make sure that AC is off.
 

Lucs_Vette

Member
Joined
Mar 1, 2006
Messages
24
Location
Kemptville, Ontario
Corvette
1985 Black Coupe
everything is turned off .. Heater, AIR, fan, radio .. anything you can turn off .. i tried removing my O2 sensor tonight .. but wouldn't come off .. i've put some liquidwrench on it .. will try again later ..

Any suggestions on removing it?

thanks all for your help and replies.
 
Joined
Jan 15, 2004
Messages
2,240
Location
Northern Indiana
Corvette
1987 Z52 Black Convertible
Since yours is a manual it might be a little different...but if I am in overdrive at say 40 and try to accelerate not very hard, just enough to keep it into OD it will "chug" going up a slight hill just momentarily until it gets up to a higher speed. Does it do it in every gear?

If you use a breaker bar on the O2 it has to come out. If you have to cut the wire and it will be easier to get a socket on the sensor.
 
R

Rufus1050

Guest
Need Help

Hi, I have an 85, also. Sounds as though you've changed some of the basics and are looking at others. I definitely would change the O2 sensor and fuel filter. Next do the fuel pressure check as someone else has suggested previously. I wouldn't rule out the possibility of an old and weak fuel pump. If you show under 40lbs start looking for a new pump. Good luck with the project and let us know what progress you make.
 
K

Key West Jack

Guest
Some fuel pumps start out ok but can not sustain volume.
 
A

AIRBUS

Guest
You might also check the pressure at your fuel pressure regulator.

If the diaphragm is going t/u, you can experience the symptoms you've described.

Good luck.
 

Lucs_Vette

Member
Joined
Mar 1, 2006
Messages
24
Location
Kemptville, Ontario
Corvette
1985 Black Coupe
hey folks,

i changed the O2 sensor with little change. so i have given up and took it to my garage for an Oil change and to replace my gas filter. once that was done i asked him to check what could be causing the stutter.

well the conclusion is the EGR valve .. he disconnected the EGR valve and it purrrrrs like a vette. told me i can still drive it but the engine light might come on. i've ordered the part and the next step is to take the whole intake out to replace it.

Thank you all for your help.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom