Welcome to the Corvette Forums at the Corvette Action Center!

Nothing electric works

Deatonj

Member
Joined
Mar 15, 2018
Messages
5
Location
Southern Illinois
Corvette
1981 red
I’ve posted previously and really appreciate the feedback. With that said I’ll bring up one of many more problems.
NOT WORKING:
*door locks
*wipers (all though there is a slight clicking sound behind passenger seat when moving switch up and down - maybe relay or something?)
*cigarette lighter
* water temp gauge (maybe sending unit?)
*power antenna
* driver’s power seat

WORKING:
*power windows (barely)
*radio
*all other gauges
*interior lights (activated by opening door)
*head lights
*turn signals
*heater
*A/C compressor kicks on but no cold air ( newer conversion to new Freon stuff but compressor looks new. Hopefully needs gas?)

I mention all the stuff in hopes there might be a common fuse or ground or something that it would point to. The wipers right now are probably the most important to get working. I’ve checked the fuse and it looks fine. Beyond that I don’t have the vaguest idea of what to do. Any help would be greatly appreciated. Thanks in advance.
 

Mac

Well-known member
Administrator
Joined
Feb 13, 2003
Messages
5,475
Location
Ottawa, Canuckistan
Corvette
1973 coupe L82 (gone as casualty of divorce)
When multiple systems are out, it's almost always a grounding issue since (theoretically) all grounds are common. That doesn't necessarily mean a single ground strap has failed; it could be more than one that is problematic. I suggest you go through and clean all of them up.

Yeah, I know it's a PITA and time consuming but no-one promised you a rose garden.

Mac
 

bill81vette

Moderator
Joined
Jan 17, 2004
Messages
4,316
Location
Troy,NY
Corvette
1981 dark blue metallic
Mac is right... check all of your grounds.Clean them up(wire brush,make sure there is no corrosion), and reinstall them and reseal them.(you buy at Napa or any good parts house).IF that doesn't work try replacing the fuse with new.
Good Luck!!


Sent from my XT1650 using Tapatalk
 

Deatonj

Member
Joined
Mar 15, 2018
Messages
5
Location
Southern Illinois
Corvette
1981 red
I’ve posted previously and really appreciate the feedback. With that said I’ll bring up one of many more problems.
NOT WORKING:
*door locks
*wipers (all though there is a slight clicking sound behind passenger seat when moving switch up and down - maybe relay or something?)
*cigarette lighter
* water temp gauge (maybe sending unit?)
*power antenna
* driver’s power seat

WORKING:
*power windows (barely)
*radio
*all other gauges
*interior lights (activated by opening door)
*head lights
*turn signals
*heater
*A/C compressor kicks on but no cold air ( newer conversion to new Freon stuff but compressor looks new. Hopefully needs gas?)

I mention all the stuff in hopes there might be a common fuse or ground or something that it would point to. The wipers right now are probably the most important to get working. I’ve checked the fuse and it looks fine. Beyond that I don’t have the vaguest idea of what to do. Any help would be greatly appreciated. Thanks in advance.

Thanks. Is there a wiring diagram or something that says where the different grounds and the system that is utilizing it are located. ( I think bad grammar there. Sorry)
 

bill81vette

Moderator
Joined
Jan 17, 2004
Messages
4,316
Location
Troy,NY
Corvette
1981 dark blue metallic
Thanks. Is there a wiring diagram or something that says where the different grounds and the system that is utilizing it are located. ( I think bad grammar there. Sorry)
Yes there are 2 if not 3-4 grounds.if you look down standing on the driver's side near the firewall, there's one in that area,there is another near the starter,and another underneath where the battery box is.all of them are on the frame. There are several wires together you will have to get underneath the Corvette to access them.do look around near the headlights and taillights as there may well be in that area as well.


Sent from my XT1650 using Tapatalk
 

Wayback

Well-known member
Joined
Aug 14, 2006
Messages
574
Location
S-NJ
Corvette
93 Ruby Aniv roadster/6spd
For some reason my main neg cable to the frame was aluminum,I changed it over to copper.That was on the 78.
Was thinking,behind the bottom left kick panel I seem to recall some grounds there also.When I removed the shifter console to install the Hurst shifter I recall a ground there.
 
Last edited:

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom