Welcome to the Corvette Forums at the Corvette Action Center!

Out of storage

wipeout

Well-known member
Joined
Jun 17, 2001
Messages
117
Location
Timmins, Ontario, Canada
Corvette
77 black coupe
Yeah I finally got my vette out of storage after like a year.

She started up right away, sounds sweet with those side pipes.

But already noticed a few things i have to fix.

1. My rear driver side caliper is leaking.

2. The motor seems to rev super high like 2000 in park. And when I floor it sounds like a bunch of marble hitting the engine. (Guessing my timing is way to advanced)

3. Im leaking oil from somewhere, seems to be coming from the timing cover or the harmonic balancer cause it spraying all over the passenger side of the engine compartment.

Is there anything I should look out for when I go to investigate. Is it more likely fromt he oil pan or the seal on my harmonic balancer.

Any tips would be great.
 
D

Dave L.

Guest
Check the valve covers first.They are the problem most of the time.I have had people tell me they needed a rear main seal replacement,when the valve covers were the problem.Work your way down from there.

Dave
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom