Welcome to the Corvette Forums at the Corvette Action Center!

Posi Question

M

MLGower

Guest
I have a question. What happens when you put 90w in a posi rear end? I have a noise in I think the diff and it only happens when turning while in gear. If I put it in nutral while turning, it's quiet. But otherwise, it sounds like old bones grinding. I was told that it was probably the Spindle berings, but after replacing one side, I still get the same noise. I really don't think that was the problem. Plus, the berings I pulled out were in excellent shape. Anyone have an idea what this could be? I ask about the diff fluid, because I'm not sure what's in it.

Thanks!!

Michael :w
 

chuck

Well-known member
Joined
Feb 7, 2001
Messages
193
Location
Tallmadge,Ohio
Corvette
1977 Dark Red Coupe/Buckskin 04 Spiral Gray/Gray
GM has a additive for posi units to keep the clutchs from sticking. If you haven't added it that is probably your problem. Chuck
 
S

sac001

Guest
Michael, drain the rear end unit, refill with the GM Positraction additive, then gear oil. The rear needs a minimum of 4 ounces, possibly more of additive, so put that in first.

Steve :w
 
M

MLGower

Guest
Cool!!! Thanks Guys, I'm goingto get this done this week. I'll let you know how it goes.

Michael
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom