Welcome to the Corvette Forums at the Corvette Action Center!

Red hot outputs@ my 89 pre-cats

C

captbane

Guest
Hi all! Heres were Im at,and its not pretty! Took the vette to a close by store,I left it at idle,when i can back out the rear of the pre-cats where so hot they glowed red!No power,she breaks up on accel. Heavy gas smell from the exhaust also.I just finished removing the main cat,the honey comb was broken and loose inside. Reinstalled...same same!(I mean thay I removed the broken stuff) I have a hypertech chip in this car,could this be a timeing problem? Checked the fuel reg vac line ,seems ok,manifold looks tight.This came on all at once.No dia. lights are on and oil pressure and temp of coolent seem about right.Oil temp also_One person said it was the pre=cats,another said its fuel pouring in because of a fuel or timeing probelem. Nither has seen the car.This is my daily driver car and I could really use some help. Thanks for looking,Douglas Castner
 

G Winter

Well-known member
Joined
Aug 21, 2004
Messages
2,177
Location
NW Iowa
Corvette
1990 red convert 6 sp
If your precats were glowing I would say they are plugged. Replace or cleanout as you did the main cat.

Glenn
:w
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom