Welcome to the Corvette Forums at the Corvette Action Center!

Turn Signals are not working

M

mmark2

Guest
The turn signals on my 93 started to flicker when they were turned on and now they don't work at all. Checked the fuse and it looks OK (will change it anyways) but is there another fuse or mudule that I should be looking at also???
 
M

mmark2

Guest
Thanks Galen, I assume it's under the dash, would you know approx. where under these it might be??
 

Galen

Well-known member
Joined
Oct 15, 2003
Messages
66
Location
Bay City MI
Corvette
1990 White/Black Interior 6sp Coupe
Mine hangs loose under the dash. I have to remove the panel under the steering wheel to get to it. Try the 4 ways if they work listen for the flasher clicking. Turn signals and flashers each have there own flasher but they are next to each other.
 
M

mmark2

Guest
Yup, the flashers work fine so it must be the turn signal unit. looked in my Haynes Manual and there's a loose description on how to remove the panel that's covering everything up, but it's pretty vague, what's the best way to take it off to get to the relay, don't want to take my roto tool to it.
 

Corvette Forums

Not a member of the Corvette Action Center?  Join now!  It's free!

Help support the Corvette Action Center!

Supporting Vendors

Dealers:

MacMulkin Chevrolet - The Second Largest Corvette Dealer in the Country!

Parts/Accessories:

Vetteskins

Advertise with the Corvette Action Center!

Double Your Chances!

Partners

Top Bottom